diff mbox series

[bug#57756,2/2] * gnu/packages/wm.scm: Add sbcl-stumpwm-notify

Message ID cb7a149a578dcd950dc6c53e2e756628305b90d1.1663018041.git.trev@trevdev.ca
State Accepted
Headers show
Series Add sbcl-xml-emitter | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Trevor Richards Sept. 12, 2022, 9:10 p.m. UTC
---
 gnu/packages/wm.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Christopher Baines Sept. 14, 2022, 7:58 a.m. UTC | #1
Trevor Richards <trev@trevdev.ca> writes:

> ---
>  gnu/packages/wm.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)

Hi Trevor,

The commit message for adding a package like this one would generally
look like:

gnu: Add sbcl-stumpwm-notify.

* gnu/packages/wm.scm (sbcl-stumpwm-notify): New variable.


You're mostly there.

> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 451dfce516..6ae0135a64 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -56,6 +56,7 @@
>  ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
>  ;;; Copyright © 2022 muradm <mail@muradm.net>
>  ;;; Copyright © 2022 Elais Player <elais@fastmail.com>
> +;;; Copyright © 2022 Trevor Richards <trev@trevdev.ca>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -2256,6 +2257,29 @@ (define-public sbcl-stumpwm-screenshot
>  PNG files.")
>      (license license:gpl3+)))
>  
> +(define-public sbcl-stumpwm-notify
> +  (package
> +    (inherit stumpwm-contrib)
> +    (name "sbcl-stumpwm-notify")
> +    (build-system asdf-build-system/sbcl)
> +    (inputs
> +     `(("stumpwm" ,stumpwm "lib")
> +       ("xml-emitter" ,sbcl-xml-emitter)
> +       ("dbus" ,sbcl-dbus)
> +       ("bordeaux-threads" ,sbcl-bordeaux-threads)))
> +    (arguments
> +     '(#:asd-systems '("notify")
> +       #:tests? #f

Why aren't the tests being run? If they can be run, that would be
good. If there's a reason why they can't or shouldn't be run, it would
be good to note that in a comment.

> +       #:phases
> +       (modify-phases %standard-phases
> +         (add-after 'unpack 'chdir
> +           (lambda _ (chdir "util/notify") #t)))))
> +    (home-page "https://github.com/stumpwm/stumpwm-contrib")
> +    (synopsis "Notifications server for StumpWM")
> +    (description "Implements org.freedesktop.Notifications
> +interface[fn:dbus-spec]. Shows notifications using stumpwm:message by default.")
> +    (license license:gpl3)))
> +
>  (define-public lemonbar
>    (package
>      (name "lemonbar")
Trevor Richards Sept. 14, 2022, 4:28 p.m. UTC | #2
Christopher Baines <mail@cbaines.net> writes:

>> ---
>>  gnu/packages/wm.scm | 24 ++++++++++++++++++++++++
>>  1 file changed, 24 insertions(+)
>
> Hi Trevor,
>
> The commit message for adding a package like this one would generally
> look like:
>
> gnu: Add sbcl-stumpwm-notify.
>
> * gnu/packages/wm.scm (sbcl-stumpwm-notify): New variable.
>
>
> You're mostly there.
>

Thank you for this feedback! I had been following the guidelines
described in the documentation:

https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html

It states to write patches in the "changelog" format described here:

https://www.gnu.org/prep/standards/html_node/Change-Logs.html#Change-Logs

Is there documentation somewhere that might help me adapt my strategy
for future contributions? I do prefer the tighter format you're asking
for :)

>> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
>> index 451dfce516..6ae0135a64 100644
>> --- a/gnu/packages/wm.scm
>> +++ b/gnu/packages/wm.scm
>> @@ -56,6 +56,7 @@
>>  ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
>>  ;;; Copyright © 2022 muradm <mail@muradm.net>
>>  ;;; Copyright © 2022 Elais Player <elais@fastmail.com>
>> +;;; Copyright © 2022 Trevor Richards <trev@trevdev.ca>
>>  ;;;
>>  ;;; This file is part of GNU Guix.
>>  ;;;
>> @@ -2256,6 +2257,29 @@ (define-public sbcl-stumpwm-screenshot
>>  PNG files.")
>>      (license license:gpl3+)))
>>  
>> +(define-public sbcl-stumpwm-notify
>> +  (package
>> +    (inherit stumpwm-contrib)
>> +    (name "sbcl-stumpwm-notify")
>> +    (build-system asdf-build-system/sbcl)
>> +    (inputs
>> +     `(("stumpwm" ,stumpwm "lib")
>> +       ("xml-emitter" ,sbcl-xml-emitter)
>> +       ("dbus" ,sbcl-dbus)
>> +       ("bordeaux-threads" ,sbcl-bordeaux-threads)))
>> +    (arguments
>> +     '(#:asd-systems '("notify")
>> +       #:tests? #f
>
> Why aren't the tests being run? If they can be run, that would be
> good. If there's a reason why they can't or shouldn't be run, it would
> be good to note that in a comment.
>

I flagged them off while testing the build in my own channel and forgot
to put them back on. Oops! They pass if they exist.

I can submit an update.

>> +       #:phases
>> +       (modify-phases %standard-phases
>> +         (add-after 'unpack 'chdir
>> +           (lambda _ (chdir "util/notify") #t)))))
>> +    (home-page "https://github.com/stumpwm/stumpwm-contrib")
>> +    (synopsis "Notifications server for StumpWM")
>> +    (description "Implements org.freedesktop.Notifications
>> +interface[fn:dbus-spec]. Shows notifications using stumpwm:message by default.")
>> +    (license license:gpl3)))
>> +
>>  (define-public lemonbar
>>    (package
>>      (name "lemonbar")
>
Christopher Baines Sept. 16, 2022, 10:25 a.m. UTC | #3
Trev <trev@trevdev.ca> writes:

> Christopher Baines <mail@cbaines.net> writes:
>
>>> ---
>>>  gnu/packages/wm.scm | 24 ++++++++++++++++++++++++
>>>  1 file changed, 24 insertions(+)
>>
>> Hi Trevor,
>>
>> The commit message for adding a package like this one would generally
>> look like:
>>
>> gnu: Add sbcl-stumpwm-notify.
>>
>> * gnu/packages/wm.scm (sbcl-stumpwm-notify): New variable.
>>
>>
>> You're mostly there.
>>
>
> Thank you for this feedback! I had been following the guidelines
> described in the documentation:
>
> https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html
>
> It states to write patches in the "changelog" format described here:
>
> https://www.gnu.org/prep/standards/html_node/Change-Logs.html#Change-Logs
>
> Is there documentation somewhere that might help me adapt my strategy
> for future contributions? I do prefer the tighter format you're asking
> for :)

I'm no expert on the changelog format, but I think you were just missing
the descriptive first line of the commit.

Looking at how other commits are written is the only recommendation I
can give for writing commit messages. Also don't worry about it too much
:)

Chris
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 451dfce516..6ae0135a64 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -56,6 +56,7 @@ 
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2022 muradm <mail@muradm.net>
 ;;; Copyright © 2022 Elais Player <elais@fastmail.com>
+;;; Copyright © 2022 Trevor Richards <trev@trevdev.ca>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2256,6 +2257,29 @@  (define-public sbcl-stumpwm-screenshot
 PNG files.")
     (license license:gpl3+)))
 
+(define-public sbcl-stumpwm-notify
+  (package
+    (inherit stumpwm-contrib)
+    (name "sbcl-stumpwm-notify")
+    (build-system asdf-build-system/sbcl)
+    (inputs
+     `(("stumpwm" ,stumpwm "lib")
+       ("xml-emitter" ,sbcl-xml-emitter)
+       ("dbus" ,sbcl-dbus)
+       ("bordeaux-threads" ,sbcl-bordeaux-threads)))
+    (arguments
+     '(#:asd-systems '("notify")
+       #:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'chdir
+           (lambda _ (chdir "util/notify") #t)))))
+    (home-page "https://github.com/stumpwm/stumpwm-contrib")
+    (synopsis "Notifications server for StumpWM")
+    (description "Implements org.freedesktop.Notifications
+interface[fn:dbus-spec]. Shows notifications using stumpwm:message by default.")
+    (license license:gpl3)))
+
 (define-public lemonbar
   (package
     (name "lemonbar")