diff mbox series

[bug#67131,v2,2/7] gnu: Add python-pyglet.

Message ID cb6eeb83-1e71-b666-cda2-46966ae802ab@disroot.org
State New
Headers show
Series [bug#67131,v2,1/7] gnu: Add python-neteria. | expand

Commit Message

Adam Faiz Nov. 13, 2023, 4:08 a.m. UTC
From 52e19861814837d58440cf628c4948a1df170146 Mon Sep 17 00:00:00 2001
Message-ID: <52e19861814837d58440cf628c4948a1df170146.1699848337.git.adam.faiz@disroot.org>
In-Reply-To: <c3534b088236ae688d64aa91046c24774ac259a6.1699848337.git.adam.faiz@disroot.org>
References: <c3534b088236ae688d64aa91046c24774ac259a6.1699848337.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Mon, 13 Nov 2023 11:39:22 +0800
Subject: [PATCH v2 2/7] gnu: Add python-pyglet.

* gnu/packages/game-development.scm (python-pyglet): New variable.
---
 gnu/packages/game-development.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index f6e3a02dea..f54b629f90 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1396,6 +1396,31 @@  (define-public python-pygame
                    license:public-domain
                    license:lgpl2.1+))))
 
+(define-public python-pyglet
+  (package
+    (name "python-pyglet")
+    (version "2.0.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pyglet" version ".zip"))
+       (sha256
+        (base32 "1jdraqr7i3bz64m7yvhcnn3av5mnavn13fp5vzmmnz6n7cdynar4"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list unzip))
+    (arguments
+     ;; TypeError: don't know how to make test from:
+     ;; <pyglet._ModuleProxy object at 0x7ffff697df90>
+     (list #:tests? #f))
+    (home-page "http://pyglet.readthedocs.org/en/latest/")
+    (synopsis "Windowing and multimedia library")
+    (description "@code{pyglet} is a windowing and multimedia library for Python,
+intended for developing games and other visually rich applications.
+It supports windowing, user interface event handling, game controllers
+and joysticks, OpenGL graphics, loading images and videos, and playing sounds
+and music.")
+    (license license:bsd-3)))
+
 (define-public python-pygame-sdl2
   (let ((real-version "2.1.0")
         (renpy-version "8.1.0"))