[bug#77275] gnu: abc: Update to 0.0-5.f5ac2d4.
Commit Message
* gnu/packages/fpga.scm (abc): Update to 0.0-5.f5ac2d4.
Change-Id: I8bdf75b6a6d61e70a252eada8b588c64261feb92
---
gnu/packages/fpga.scm | 64 +++++++++++++++++++++----------------------
1 file changed, 32 insertions(+), 32 deletions(-)
base-commit: 24effa5fc281553a2062f0171cc07ea03db2ecf1
@@ -80,39 +80,39 @@ (define-module (gnu packages fpga)
#:use-module (gnu packages version-control))
(define-public abc
- (let ((commit "d5e1a5d445f68bdb4895bb735b9568e5f4738c13")
- (revision "4"))
- (package
- (name "abc")
- (version (git-version "0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/berkeley-abc/abc")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0b3qdljcr7dznqr3zxihx9vp6ng6a6pnaqhasblc03rnpp83y1w4"))))
- (build-system gnu-build-system)
- (inputs
- (list readline))
- (arguments
- (list #:license-file-regexp "copyright.txt"
- #:tests? #f ; no tests
- #:phases
- #~(modify-phases %standard-phases
- (delete 'configure)
- (replace 'install
- (lambda _
- (install-file "abc" (string-append #$output "/bin")))))))
- (home-page "https://people.eecs.berkeley.edu/~alanmi/abc/")
- (synopsis "Sequential logic synthesis and formal verification")
- (description "ABC is a program for sequential logic synthesis and
+ (let ((commit "f5ac2d4bd3fc749825795f18c795513e2e85a3b1")
+ (revision "5"))
+ (package
+ (name "abc")
+ (version (git-version "0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/berkeley-abc/abc")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vvw14ybgf8gbrw41bkwjb2hsp3yil8bhy2bh7j60lgwrp73af26"))))
+ (build-system gnu-build-system)
+ (inputs
+ (list readline))
+ (arguments
+ (list #:license-file-regexp "copyright.txt"
+ #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda _
+ (install-file "abc" (string-append #$output "/bin")))))))
+ (home-page "https://people.eecs.berkeley.edu/~alanmi/abc/")
+ (synopsis "Sequential logic synthesis and formal verification")
+ (description "ABC is a program for sequential logic synthesis and
formal verification.")
- (license
- (license:non-copyleft
- "https://people.eecs.berkeley.edu/~alanmi/abc/copyright.htm")))))
+ (license
+ (license:non-copyleft
+ "https://people.eecs.berkeley.edu/~alanmi/abc/copyright.htm")))))
(define-public iverilog
(package