diff mbox series

[bug#38124] gnu: Add zam-plugins.

Message ID cb45fcab16216bcf02e34e4e876b98f5669883ea.camel@zrythm.org
State Accepted
Headers show
Series [bug#38124] gnu: Add zam-plugins. | expand

Commit Message

Alexandros Theodotou Nov. 11, 2019, 3:06 a.m. UTC
Updated and clarified on DPF

Comments

Marius Bakke Nov. 13, 2019, 10:26 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> From 10b8905b8e117d68e6b8b8f86087111a1fb5dae8 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 10:35:27 +0000
> Subject: [PATCH] gnu: Add zam-plugins.
>
> * gnu/packages/music.scm: (zam-plugins): New variable.

Applied after changing indentation and adjusting description to appease
`guix lint`.

[...]

> +        (file-name (string-append name "-" version))

I also changed this to use 'git-file-name'.

Thanks!
diff mbox series

Patch

From 10b8905b8e117d68e6b8b8f86087111a1fb5dae8 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 10:35:27 +0000
Subject: [PATCH] gnu: Add zam-plugins.

* gnu/packages/music.scm: (zam-plugins): New variable.
---
 gnu/packages/music.scm | 52 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 52 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2f023685df..17288f845f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4737,3 +4737,55 @@  for integration into status line generators or other command-line tools.")
 effects.  It contains a bitcrusher, delay, distortion, equalizer, compressor,
 and reverb.")
     (license license:gpl2+)))
+
+(define-public zam-plugins
+  (package
+    (name "zam-plugins")
+    (version "3.11")
+    (source
+      (origin
+        (method git-fetch)
+        (uri
+          (git-reference
+            (url "https://github.com/zamaudio/zam-plugins.git")
+            (commit version)
+            ;; Recursive to fetch the DISTRHO plugin framework. This
+            ;; framework is intended to be included in the sources
+            ;; and not to be used as a library
+            (recursive? #t)))
+        (file-name (string-append name "-" version))
+        (sha256
+          (base32
+            "0jlbxm0g93plgd3g4r9rsr0c7868ms49bs0ljpqb6kw6132hsapp"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f  ; no "check" target
+       #:make-flags
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+             "HAVE_ZITA_CONVOLVER=true")
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'set-CC-variable
+           (lambda _
+             (setenv "CC" "gcc") #t))
+         (delete 'configure))))
+    (inputs
+     `(("fftwf" ,fftwf)
+       ("jack" ,jack-1) ; for the standalone JACK application
+       ("liblo" ,liblo)
+       ("libsamplerate" ,libsamplerate)
+       ("mesa" ,mesa)
+       ("zita-convolver" ,zita-convolver)))
+    (native-inputs
+     `(("ladspa" ,ladspa)
+       ("lv2" ,lv2)
+       ("pkg-config" ,pkg-config)))
+    (synopsis "Collection of audio processing plugins")
+    (description
+     "Zam plugins is a collection of audio processing plugins in the LADSPA,
+LV2 and VST2 formats, as well as standalone JACK versions. The collection
+includes ZaMaximX2, ZamAutoSat, ZamComp, ZamCompX2, ZamEQ2, ZamGEQ31,
+ZamHeadX2, ZamPhono, ZamGate, ZamGateX2, ZamTube, ZamDelay, ZamDynamicEQ,
+ZaMultiComp, ZaMultiCompX2 and ZamSynth.")
+    (home-page "http://www.zamaudio.com/?p=976")
+    (license license:gpl2+)))
-- 
2.24.0