[bug#71780,v3,5/7] gnu: Add go-github-com-emersion-go-vcard.
Commit Message
* gnu/packages/golang.scm (go-github-com-emersion-go-vcard): New variable.
Change-Id: I455fda8050424e7263ceb23e0d55520336b73223
---
gnu/packages/golang.scm | 93 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 93 insertions(+)
@@ -5984,6 +5984,99 @@ (define-public go-github-com-emersion-go-mbox
@code{mbox} files.")
(license license:expat)))
+(define-public go-github-com-emersion-go-vcard
+ (package
+ (name "go-github-com-emersion-go-vcard")
+ (version "0.0.0-20230815062825-8fda7d206ec9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-vcard")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "12n5jinj5xzdfl9jhqvjbzxvj32bw310mdw4q5rjv35pk566zixl"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/emersion/go-vcard"))
+ (home-page "https://github.com/emersion/go-vcard")
+ (synopsis "Go library to parse and format vCard")
+ (description "A Go library to parse and format vCard.")
+ (license license:expat)))
+
+(define-public go-github-com-teambition-rrule-go
+ (package
+ (name "go-github-com-teambition-rrule-go")
+ (version "1.8.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/teambition/rrule-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fnbava35w9z60carny5b7whd4nkv6hrf9g43wwg8d88gfij9zj2"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/teambition/rrule-go"))
+ (home-page "https://github.com/teambition/rrule-go")
+ (synopsis
+ "Go library for working with recurrence rules for calendar dates")
+ (description
+ "A go library for working with recurrence rules for calendar dates.")
+ (license license:expat)))
+
+(define-public go-github-com-emersion-go-ical
+ (package
+ (name "go-github-com-emersion-go-ical")
+ (version "0.0.0-20240127095438-fc1c9d8fb2b6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-ical")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01cn9kggkdalb6xp2nrka01gs40zs8v6h5bq8d2m8wrdcsy5b36v"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/emersion/go-ical"))
+ (propagated-inputs (list go-github-com-teambition-rrule-go))
+ (home-page "https://github.com/emersion/go-ical")
+ (synopsis "Go library for iCalendar")
+ (description "An iCalendar library for Go.")
+ (license license:expat)))
+
+(define-public go-github-com-emersion-go-webdav
+ (package
+ (name "go-github-com-emersion-go-webdav")
+ (version "v0.3.2-0.20220524091811-5d845721d8f7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emersion/go-webdav")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vxf9k7m4lxsyry374bm4y34d2sb2ssy0c45mb1vchdfhffgyj9i"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/emersion/go-webdav"))
+ (propagated-inputs (list go-github-com-emersion-go-ical
+ go-github-com-emersion-go-vcard))
+ (home-page "https://github.com/emersion/go-webdav")
+ (synopsis "Go library for WebDAV, CalDAV and CardDAV")
+ (description "A Go library for WebDAV, CalDAV and CardDAV.")
+ (license license:expat)))
+
(define-public go-github-com-google-go-cmp-cmp
(package
(name "go-github-com-google-go-cmp-cmp")