[bug#75441,1/3] gnu: Add boost-1.74.0.

Message ID cb30af49420be6085f0d091952712ec8b38122a4.1736357207.git.rocktakey@gmail.com
State New
Headers
Series [bug#75441,1/3] gnu: Add boost-1.74.0. |

Commit Message

ROCKTAKEY Jan. 8, 2025, 5:40 p.m. UTC
  Change-Id: Iddd713d958b052517e1819d2abd926cd1210126c
---
 gnu/packages/boost.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: 5d9e839fce98c49a8db47422a050ce03d799fe02
  

Comments

Takeda Yuki Jan. 8, 2025, 5:56 p.m. UTC | #1
I made a mistake in using mumi. I apologize.
  

Patch

diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index d090c52d8d..f560ca0800 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2021, 2022 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2021 Franck Pérignon <franck.perignon@univ-grenoble-alpes.fr>
 ;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
+;;; Copyright © 2025 ROCKTAKEY <rocktakey@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -361,6 +362,30 @@  (define-public boost-for-mysql
        (delete "python-minimal-wrapper")))
     (properties '((hidden? . #t)))))
 
+(define-public boost-for-siv3d
+  (package
+    (inherit boost)
+    (version "1.74.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://boostorg.jfrog.io/artifactory/main/release/"
+                                  version "/source/boost_"
+                                  (version-with-underscores version) ".tar.bz2"))
+              (sha256
+               (base32
+                "1c8nw4jz17zy2y27h7p554a5jza1ymz8phkz71p9181ifx8c3gw3"))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments boost)
+       ((#:phases phases)
+        #~(modify-phases #$phases
+            (add-before 'configure 'substitute-for-python-compatibility
+              (lambda _
+                ;; For compatibility to Python 3.10.
+               ;; Retrived from future commit:
+               ;; https://github.com/boostorg/python/commit/cbd2d9f033c61d29d0a1df14951f4ec91e7d05cd
+               (substitute* '("libs/python/src/exec.cpp")
+                 (("_Py_fopen") "fopen"))))))))))
+
 (define-public boost-sync
   (let ((commit "e690de2d30e2f1649ff500c9a6f3539814994b1c")
         (version "1.55")