[bug#75088,5/7] gnu: Add python-types-simplejson.

Message ID cb10c818ce8a1cf403c995fb3f7c341672b53d69.1735134164.git.sarg@sarg.org.ru
State New
Headers
Series Fix beancount and fava builds. |

Commit Message

Sergey Trofimov Dec. 25, 2024, 2:01 p.m. UTC
  * gnu/packages/python-xyz.scm (python-types-simplejson): New variable.
---
 gnu/packages/python-xyz.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d5a5dcb878..a75a1992f5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -37212,6 +37212,23 @@  (define-public python-types-requests
     (description "This package provides typing stubs for requests.")
     (license license:asl2.0)))
 
+(define-public python-types-simplejson
+  (package
+    (name "python-types-simplejson")
+    (version "3.17.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "types-simplejson" version))
+       (sha256
+        (base32 "1a3gphpjkb315i7l48l6g1rch3nr43k1f7rgalfsdr7897fyv8pz"))))
+    (build-system python-build-system)
+    (native-inputs (list python-setuptools python-wheel))
+    (home-page "https://github.com/python/typeshed")
+    (synopsis "Typing stubs for simplejson")
+    (description "Typing stubs for simplejson.")
+    (license license:asl2.0)))
+
 (define-public python-types-setuptools
   (package
     (name "python-types-setuptools")