diff mbox series

[bug#67338,gnome-team,WIP] gnu: Add gnome-logs.

Message ID cb004aa4374347f7a2391fa03c1568688a093c30.1700595030.git.vivien@planete-kraus.eu
State New
Headers show
Series [bug#67338,gnome-team,WIP] gnu: Add gnome-logs. | expand

Commit Message

Vivien Kraus Nov. 21, 2023, 5:54 p.m. UTC
gnome-logs does not appear to support elogind as a journal provider, because
it crashes on startup.

* gnu/packages/gnome.scm (gnome-logs): New variable.

Change-Id: I3d4fff870b5b0d10bcd229c164a5bb19564880d7
---
 gnu/packages/gnome.scm | 45 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)


base-commit: 1cc3b7e80f60a2a5a6a1400ed0b025efeae7a523

Comments

Liliana Marie Prikler Nov. 21, 2023, 8:28 p.m. UTC | #1
Am Dienstag, dem 21.11.2023 um 18:54 +0100 schrieb Vivien Kraus:
> gnome-logs does not appear to support elogind as a journal provider,
> because it crashes on startup.
> 
> * gnu/packages/gnome.scm (gnome-logs): New variable.
Yeah, this is pretty much useless in Guix.  gnome-logs requires
systemd-journald, whereas we use syslogd.  I think it's safe to ship
our GNOME 44 without it.

Cheers
Vivien Kraus Jan. 29, 2024, 6:15 p.m. UTC | #2
I’m retracting this, it is obviously out of scope.

Best regards,

Vivien
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ab485cffb1..61edd70d93 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -13218,6 +13218,51 @@  (define-public komikku
 developed with the aim of being used with the Librem 5 phone.")
     (license license:gpl3+)))
 
+(define-public gnome-logs
+  ;; FIXME: crashes at startup because elogind does not implement the
+  ;; requested API.
+  (package
+    (name "gnome-logs")
+    (version "43.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/" name "/"
+                                  (version-major version) "/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0q88q8z7paq2r5s7pkxbclsw5mgpi9xslj2hha3q8z62bsbkpa9k"))))
+    (build-system meson-build-system)
+    (arguments
+     (list
+      #:glib-or-gtk? #t
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'skip-icon-cache
+            (lambda _
+              (substitute* "meson_post_install.py"
+                (("gtk-update-icon-cache")
+                 "true"))))
+          (add-after 'unpack 'use-elogind
+            (lambda _
+              (substitute* "src/gl-journal.h"
+                (("systemd/sd-([^.]*)\\.h" all header)
+                 (string-append "elogind/sd-" header ".h")))
+              (substitute* "meson.build"
+                (("'libsystemd'")
+                 "'libelogind'")))))))
+    (inputs
+     (list elogind glib gtk libadwaita))
+    (native-inputs
+     (list gettext-minimal
+           `(,glib "bin")
+           itstool
+           pkg-config))
+    (home-page "https://apps.gnome.org/Logs")
+    (synopsis "View detailed event logs for the system")
+    (description "This application shows events from the system journal.")
+    (license license:gpl3+)))
+
 (define-public libgda
   (package
     (name "libgda")