diff mbox series

[bug#63707] gnu: Add font-ipa.

Message ID cac4f8d139c62bae4464276a9a5e2bc71ea89fc8.1684963373.git.wolf@wolfsden.cz
State New
Headers show
Series [bug#63707] gnu: Add font-ipa. | expand

Commit Message

Tomas Volf May 24, 2023, 9:22 p.m. UTC
* gnu/packages/fonts.scm (font-ipa): New variable.
---
 gnu/packages/fonts.scm | 46 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)


base-commit: 6d0571215d661d21cac2150ca45906e77a79a5fb

Comments

Tomas Volf June 21, 2023, 4:36 p.m. UTC | #1
Hi,

anything I can do to help this getting merged?

W.
Nicolas Goaziou July 1, 2023, 10:23 a.m. UTC | #2
Hello,

Wolf <wolf@wolfsden.cz> writes:

> * gnu/packages/fonts.scm (font-ipa): New variable.

Applied with the changes below. Thank you.
> ---
> +    (build-system font-build-system)
> +    (arguments
> +     (list #:phases #~(modify-phases %standard-phases
> +                        (add-after 'unpack 'make-read-only

I fixed indentation, which consumes way too much horizontal space here.

> +                        (add-after 'install 'install-doc
> +                          (lambda* (#:key outputs #:allow-other-keys)

outputs argument is not necessary when using G-expressions. You don't
use it either in your phases.

> +    (description "Japanese outline fonts by Information-technology Promotion
> +Agency, Japan (IPA)")

The description should consist of full sentences:

  "These package provides Japanese outline fonts..."

Regards,
Tomas Volf July 2, 2023, 6:10 p.m. UTC | #3
On 2023-07-01 12:23:34 +0200, Nicolas Goaziou wrote:
> Hello,
> 
> Wolf <wolf@wolfsden.cz> writes:
> 
> > * gnu/packages/fonts.scm (font-ipa): New variable.
> 
> Applied with the changes below. Thank you.

Thank you for merging it.

> > ---
> > +    (build-system font-build-system)
> > +    (arguments
> > +     (list #:phases #~(modify-phases %standard-phases
> > +                        (add-after 'unpack 'make-read-only
> 
> I fixed indentation, which consumes way too much horizontal space here.
> 
> > +                        (add-after 'install 'install-doc
> > +                          (lambda* (#:key outputs #:allow-other-keys)
> 
> outputs argument is not necessary when using G-expressions. You don't
> use it either in your phases.

I admit I just copied over the package for font-ipa-ex and adjusted it, not
realizing that this part is not necessary.

> 
> > +    (description "Japanese outline fonts by Information-technology Promotion
> > +Agency, Japan (IPA)")
> 
> The description should consist of full sentences:
> 
>   "These package provides Japanese outline fonts..."

Will keep that in mind.

> 
> Regards,
> -- 
> Nicolas Goaziou

Have a nice day,
W.
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 12c6b04bd7..b159eb7ab0 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2515,6 +2515,52 @@  (define-public font-meera-inimai
 characteristic so that they sit smoothly with the Tamil glyphs.")
     (license license:silofl1.1)))
 
+(define-public font-ipa
+  (package
+    (name "font-ipa")
+    (version "003.03")
+    (source (origin
+              (method url-fetch/zipbomb)
+              (uri (string-append
+                    "https://moji.or.jp/wp-content/ipafont/IPAfont/" "IPAfont"
+                    (string-join (string-split version #\.) "") ".zip"))
+              (sha256
+               (base32
+                "1rbgfq14ld0cwas6bx5h7pwyv2hkfa8ihnphsaz1brxqliwysmgp"))))
+    (build-system font-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (add-after 'unpack 'make-read-only
+                          (lambda _
+                            ;; Otherwise the files have the executable bit set.
+                            (for-each (lambda (file)
+                                        (chmod file #o444))
+                                      (find-files "."
+                                                  #:directories? #f))))
+                        (add-after 'install 'install-doc
+                          (lambda* (#:key outputs #:allow-other-keys)
+                            (let ((font+version #$(string-append "IPAfont"
+                                                                 (string-join (string-split
+                                                                               version
+                                                                               #\.)
+                                                                  "")))
+                                  (doc-dir (string-append #$output
+                                                          "/share/doc/"
+                                                          #$name)))
+                              (with-directory-excursion font+version
+                                (mkdir-p doc-dir)
+                                (copy-file (string-append "Readme_"
+                                                          font+version ".txt")
+                                           (string-append doc-dir "/README"))
+                                (copy-file
+                                 "IPA_Font_License_Agreement_v1.0.txt"
+                                 (string-append doc-dir "/LICENSE")))))))))
+    (home-page "https://moji.or.jp/ipafont/")
+    (synopsis "Japanese font from the Information-technology Promotion Agency")
+    (description "Japanese outline fonts by Information-technology Promotion
+Agency, Japan (IPA)")
+    (license license:ipa)))
+
 (define-public font-ipa-ex
   (package
     (name "font-ipa-ex")