diff mbox series

[bug#67352] gnu: Add emacs-sql-indent.

Message ID cac29db99433492e819ec51aa423bea4fed09526.1700605952.git.ian@retrospec.tv
State New
Headers show
Series [bug#67352] gnu: Add emacs-sql-indent. | expand

Commit Message

Ian Eure Nov. 21, 2023, 10:32 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-sql-indent): New variable.

Change-Id: I56a5f1c2e5256ed2ebcfe58ff99faffe49bf8519
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: 42be8fa560a7554ac35801b46c3a0a007fd742ce

Comments

Nicolas Goaziou Jan. 4, 2024, 11:34 a.m. UTC | #1
Hello,

Ian Eure <ian@retrospec.tv> writes:

> * gnu/packages/emacs-xyz.scm (emacs-sql-indent): New variable.

Applied. Thank you.

I truncated description and removed parts of it that should belong to
the manual instead.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 90fe9fceeb..07d9ee280f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22444,6 +22444,30 @@  (define-public emacs-closql
 add any additional instance slots.")
     (license license:gpl3)))
 
+(define-public emacs-sql-indent
+  (package
+    (name "emacs-sql-indent")
+    (version "1.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://elpa.gnu.org/packages/sql-indent-" version
+                           ".tar"))
+       (sha256
+        (base32 "043qcy97a5hx68w0ac7xsk380l2i7bphgrdz6aby2zfpp90vrjpn"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/alex-hhh/emacs-sql-indent")
+    (synopsis "Support for indenting code in SQL files")
+    (description
+     "This package provides a minor mode that enables syntax-based indentation for
+@code{sql-mode} buffers: the TAB key indents the current line based on the SQL code on
+previous lines.  To setup syntax-based indentation for every SQL buffer, add
+@code{sqlind-minor-mode} to @code{sql-mode-hook}.  Indentation rules are flexible and can
+be customized to match your personal coding style.  For more information, see
+the \"sql-indent.org\" file.  The package also defines align rules so that the
+align function works for SQL statements, see @code{sqlind-align-rules}.")
+    (license license:gpl3+)))
+
 (define-public emacs-epkg
   (package
     (name "emacs-epkg")