diff mbox series

[bug#69676] gnu: emacs-org-pandoc-import: Update to 1.0-0.db308f1.

Message ID ca669ec45c24328fc5910c3f85e9175a6efa0bc3.1709982177.git.csantosb@inventati.org
State New
Headers show
Series [bug#69676] gnu: emacs-org-pandoc-import: Update to 1.0-0.db308f1. | expand

Commit Message

Cayetano Santos March 9, 2024, 11:02 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-org-pandoc-import): Update to 1.0-0.db308f1.

Last stable 1.0 version dates back from 3 years ago.

---
 gnu/packages/emacs-xyz.scm | 63 ++++++++++++++++++++------------------
 1 file changed, 33 insertions(+), 30 deletions(-)


base-commit: 1bc05c6f6d56ad9e0e31d7f1cc75545a65e3d0f3
--
2.41.0

Comments

Nicolas Goaziou March 13, 2024, 8:48 a.m. UTC | #1
Hello,

Cayetano Santos via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-org-pandoc-import): Update to
> 1.0-0.db308f1.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7fa5df9202..4c51783f86 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11287,41 +11287,44 @@  (define-public emacs-org-superstar
     (license license:gpl3+)))
 
 (define-public emacs-org-pandoc-import
-  (package
-    (name "emacs-org-pandoc-import")
-    (version "1.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/tecosaur/org-pandoc-import/")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "00z9bpm975mlyqlxbyib3j547br6kvcam04b70qkmq22vh8yf341"))))
-    (build-system emacs-build-system)
-    (arguments
-     `(#:include
-       (cons* "^filters\\/" "^preprocessors" %default-include)
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-exec-paths
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((pandoc (assoc-ref inputs "pandoc")))
-               (substitute* "org-pandoc-import.el"
-                 (("\"pandoc\"") (string-append "\"" pandoc "/bin/pandoc\"")))))))))
-    (inputs
-     (list pandoc))
-    (home-page "https://github.com/tecosaur/org-pandoc-import/")
-    (synopsis "Read and edit non-Org file types in Org")
-    (description
-     "This package uses Pandoc to convert selected file types to Org.  It can
+  (let ((commit "db308f1a05be26ce5b287633637ce554599b1377")
+        (revision "0"))
+    (package
+      (name "emacs-org-pandoc-import")
+      (version (git-version "1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/tecosaur/org-pandoc-import/")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "19z1qaairhpj8kyyqwx8yf53j3f03a9a1z1jfa348qmncnra5jmh"))))
+      (build-system emacs-build-system)
+      (arguments
+       `(#:include
+         (cons* "^filters\\/" "^preprocessors" %default-include)
+         #:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'patch-exec-paths
+             (lambda* (#:key inputs #:allow-other-keys)
+               (let ((pandoc (assoc-ref inputs "pandoc")))
+                 (substitute* "org-pandoc-import.el"
+                   (("\"pandoc\"")
+                    (string-append "\"" pandoc "/bin/pandoc\"")))))))))
+      (inputs
+       (list pandoc))
+      (home-page "https://github.com/tecosaur/org-pandoc-import/")
+      (synopsis "Read and edit non-Org file types in Org")
+      (description
+       "This package uses Pandoc to convert selected file types to Org.  It can
 convert supported non-Org files to an Org file with Pandoc.
 
 It can also intercept requests for non-Org files it knows it can convert,
 convert the file to a temporary Org file, and open this file instead.  On
 save, it exports back to the original non-Org file.")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-org-pomodoro
   ;; Last release version was from 2016.