diff mbox series

[bug#70924,08/10] gnu: Add python-primecountpy.

Message ID ca3f9049e9957d08a0f0c5e89cc3ece31d68e50d.1715633288.git.monego@posteo.net
State New
Headers show
Series Add some SageMath standard packages. | expand

Commit Message

Vinicius Monego May 13, 2024, 8:52 p.m. UTC
* gnu/packages/maths.scm (python-primecountpy): New variable.

Change-Id: Id775a672c104162965825d8d44e599df0c26f11a
---
 gnu/packages/maths.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1740a55cf4..8792f9df06 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1360,6 +1360,28 @@  (define-public primecount
 optimized implementations of the combinatorial prime counting algorithms.")
     (license license:bsd-2)))
 
+(define-public python-primecountpy
+  (package
+    (name "python-primecountpy")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "primecountpy" version))
+       (sha256
+        (base32 "0xh6zx5zw5scy7jygqirks9y6z4zyfm0zjfp8nd6dw0m471przkq"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:tests? #f)) ; there are no tests
+    (native-inputs (list python-cysignals python-cython))
+    (inputs (list pari-gp primecount))
+    (home-page "https://github.com/dimpase/primecountpy")
+    (synopsis "Cython interface for C++ primecount library")
+    (description "This package provides a Cython interface to the C++ library
+@code{primecount}.")
+    ;; pyproject.toml says gpl3 but file headers say gpl2+.
+    (license license:gpl2+)))
+
 (define-public giza
   (package
     (name "giza")