diff mbox series

[bug#61586,RFC,1/2] gnu: Add python-filecheck.

Message ID ca155e12553a1d104c4b8d14343c8d68a640a09f.camel@gmail.com
State New
Headers show
Series Add BinaryEn | expand

Commit Message

Liliana Marie Prikler Feb. 17, 2023, 8:27 p.m. UTC
* gnu/packages/check.scm (python-filecheck): New variable.
---
 gnu/packages/check.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 3d14cb7585..c4e83d41ef 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2364,6 +2364,31 @@  (define-public python-lit
 failures.")
     (license license:ncsa)))
 
+(define-public python-filecheck
+  (package
+    (name "python-filecheck")
+    (version "0.0.23")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mull-project/FileCheck.py")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1gipw7x54nr6raxr681igpxn8jli5mwaznnj40xxks0pa5kvirs7"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-lit python-pytest python-pylint
+                         python-invoke poetry))
+    (home-page "https://filecheck.readthedocs.io/")
+    (synopsis "Pattern matching file verifier")
+    (description
+     "This package provides a Python port of LLVM's FileCheck utility.  It
+can be used to assert that certain strings (or regular expressions) are present
+or missing in a given file.  A typical application is the post-processing of
+test logs.")
+    (license license:asl2.0)))
+
 ;;; This is marked as a bootstrap package because it propagates bootstrapped
 ;;; versions of jaraco-context and jaraco-functools.
 (define-public python-pytest-enabler-bootstrap