diff mbox series

[bug#63080] * gnu: Move stalonetray to (gnu packages xdisorg).

Message ID c9d79f9e004ee2ef8dd7d676a8a5d1615b2907ab.1686007100.git.kiasoc5@disroot.org
State New
Headers show
Series [bug#63080] * gnu: Move stalonetray to (gnu packages xdisorg). | expand

Commit Message

kiasoc5 June 5, 2023, 11:18 p.m. UTC
See <https://issues.guix.gnu.org/63080>.

* gnu/packages/stalonetray.scm (stalonetray): Move from here…
* gnu/packages/xdisorg.scm (stalonetray): …to here.
* gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly.
---
 gnu/local.mk                 |  1 -
 gnu/packages/stalonetray.scm | 69 ------------------------------------
 gnu/packages/xdisorg.scm     | 41 +++++++++++++++++++++
 3 files changed, 41 insertions(+), 70 deletions(-)
 delete mode 100644 gnu/packages/stalonetray.scm


base-commit: f598f5b870462afbb5a5770c1b16071bca63fc52
prerequisite-patch-id: 45ae29dd8297f83231b66d1fc3f357b903f7a080
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index f9afb433e6..69b7d511a0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -586,7 +586,6 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/squirrel.scm			\
   %D%/packages/ssh.scm				\
   %D%/packages/sssd.scm				\
-  %D%/packages/stalonetray.scm			\
   %D%/packages/statistics.scm			\
   %D%/packages/stb.scm				\
   %D%/packages/stenography.scm			\
diff --git a/gnu/packages/stalonetray.scm b/gnu/packages/stalonetray.scm
deleted file mode 100644
index a9d842a99e..0000000000
--- a/gnu/packages/stalonetray.scm
+++ /dev/null
@@ -1,69 +0,0 @@ 
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Raimon Grau <raimonster@gmail.com>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages stalonetray)
-  #:use-module (guix gexp)
-  #:use-module (guix packages)
-  #:use-module (guix git-download)
-  #:use-module (guix build-system gnu)
-  #:use-module ((guix licenses) #:select (gpl2+))
-  #:use-module (gnu packages autotools)
-  #:use-module (gnu packages docbook)
-  #:use-module (gnu packages xml)
-  #:use-module (gnu packages xorg))
-
-(define-public stalonetray
-  (package
-    (name "stalonetray")
-    (version "0.8.5")
-    (source
-     (origin
-       (method git-fetch)
-       (uri
-	(git-reference
-	 (url "https://github.com/kolbusa/stalonetray")
-	 (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-	(base32
-	 "074wy1xppfycillbxq6fwrq87ik9glc95083df5vgm20mhzni7pz"))))
-    (arguments
-     (list
-      #:phases
-      #~(modify-phases %standard-phases
-	  (add-after 'unpack 'fix-docbook-root
-	    (lambda _
-	      (substitute* "configure.ac"
-		(("AC_SUBST\\(DOCBOOK_ROOT\\)" all)
-		 (string-append "DOCBOOK_ROOT="
-				#$(this-package-native-input "docbook-xsl")
-				"/xml/xsl/docbook-xsl-"
-				#$(package-version (this-package-native-input "docbook-xsl"))
-				"; " all))))))))
-    (inputs (list libx11 libxpm))
-    (native-inputs (list autoconf automake docbook-xsl libxslt))
-    (build-system gnu-build-system)
-    (home-page "https://kolbusa.github.io/stalonetray")
-    (synopsis "Standalone freedesktop.org and KDE systray implementation")
-    (description
-     "Stalonetray is a stand-alone freedesktop.org and KDE system
-tray (notification area) for X Window System/X11 (e.g. X.Org or XFree86).  It
-has full XEMBED support and minimal dependencies: an X11 lib only.  Stalonetray
-works with virtually any EWMH-compliant window manager.")
-    (license gpl2+)))
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index b8671d1cf6..615ac32aa0 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -102,6 +102,7 @@  (define-module (gnu packages xdisorg)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages cpp)
   #:use-module (gnu packages datastructures)
+  #:use-module (gnu packages docbook)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages fontutils)
@@ -2002,6 +2003,46 @@  (define-public tint2
 actions, a built-in clock, a battery monitor and a system tray.")
     (license license:gpl2)))
 
+(define-public stalonetray
+  (package
+    (name "stalonetray")
+    (version "0.8.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+	(git-reference
+	 (url "https://github.com/kolbusa/stalonetray")
+	 (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+	(base32
+	 "074wy1xppfycillbxq6fwrq87ik9glc95083df5vgm20mhzni7pz"))))
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+	  (add-after 'unpack 'fix-docbook-root
+	    (lambda _
+	      (substitute* "configure.ac"
+		(("AC_SUBST\\(DOCBOOK_ROOT\\)" all)
+		 (string-append "DOCBOOK_ROOT="
+				#$(this-package-native-input "docbook-xsl")
+				"/xml/xsl/docbook-xsl-"
+				#$(package-version (this-package-native-input "docbook-xsl"))
+				"; " all))))))))
+    (inputs (list libx11 libxpm))
+    (native-inputs (list autoconf automake docbook-xsl libxslt))
+    (build-system gnu-build-system)
+    (home-page "https://kolbusa.github.io/stalonetray")
+    (synopsis "Standalone freedesktop.org and KDE systray implementation")
+    (description
+     "Stalonetray is a stand-alone freedesktop.org and KDE system
+tray (notification area) for X Window System/X11 (e.g. X.Org or XFree86).  It
+has full XEMBED support and minimal dependencies: an X11 lib only.  Stalonetray
+works with virtually any EWMH-compliant window manager.")
+    (license license:gpl2+)))
+
 (define-public tofi
   (package
     (name "tofi")