diff mbox series

[bug#68278] Add laszip 3.4.3

Message ID c9ce3b33-1e76-4856-a8af-47660744b872@ign.fr
State New
Headers show
Series [bug#68278] Add laszip 3.4.3 | expand

Commit Message

Mattia Bunel Jan. 5, 2024, 6:46 p.m. UTC
Hi,

This is a patch for add the laszip lib to guix.  This is my first 
contribution to the project, so chances are it won't be perfect. Don't 
hesitate to give me feedback, it'll help me with future patches.

Comments

Mathieu Othacehe Jan. 7, 2024, 6:22 p.m. UTC | #1
Hello,

Welcome aboard!

>
> ---

You are missing a commit message that follows those rules:
https://www.gnu.org/prep/standards/html_node/Change-Logs.html#Change-Logs.

You can have a look to the git log for examples.

> +    (home-page "https://laszip.org/")
> +    (synopsis "Compression library for LAS files")
> +    (description
> +     "LASzip is a library for compress las files and uncompress laz files.")

I expanded a bit the description before applying,

Thanks,

Mathieu
diff mbox series

Patch

From 4b06d664319b0783bd972f591e56bbc446a7bc62 Mon Sep 17 00:00:00 2001
From: Mattia Bunel <mattia.bunel@ign.fr>
Date: Fri, 5 Jan 2024 14:50:53 +0100
Subject: [PATCH] Add laszip 3.4.3

---
 gnu/packages/geo.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 31abb2cc36..024b3a419c 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -3228,3 +3228,29 @@  (define-public navit
 file format, and data from OpenStreetMap, Garmin maps, Marco Polo
 Grosser Reiseplaner, Routeplaner Europa 2007, Map + Route.")
     (license license:gpl2)))
+
+(define-public laszip
+  (package
+    (name "laszip")
+    (version "3.4.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/LASzip/LASzip")
+             (commit "3.4.3")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "09lcsgxwv0jq50fhsgfhx0npbf1zcwn3hbnq6q78fshqksbxmz7m"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:configure-flags #~(list "-DLASZIP_BUILD_STATIC=NO")
+      #:build-type "Release"
+      ;; No tests writed
+      #:tests? #f))
+    (home-page "https://laszip.org/")
+    (synopsis "Compression library for LAS files")
+    (description
+     "LASzip is a library for compress las files and uncompress laz files.")
+    (license license:asl2.0)))
\ No newline at end of file
-- 
2.34.1