diff mbox series

[bug#56276,1/2] gnu: gdk-pixbuf: Remove unnecessary dependency.

Message ID c9b357baf19c33c14b3abbeee533104da360044c.1656419649.git.tj@schwi.pl
State Accepted
Headers show
Series gnu: Add gdk-pixbuf-xlib. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Tomasz Jeneralczyk June 28, 2022, 1:21 p.m. UTC
* gnu/packages/gtk.scm (gtk-pixbuf): Remove libx11 from native-inputs

gdk-pixbuf-xlib was split into its own library in gdk-pixbuf version 2.42.0:
https://gitlab.gnome.org/GNOME/gdk-pixbuf/-/tags/2.42.0
---
 gnu/packages/gtk.scm | 2 --
 1 file changed, 2 deletions(-)

Comments

Liliana Marie Prikler June 28, 2022, 12:38 p.m. UTC | #1
Am Dienstag, dem 28.06.2022 um 13:21 +0000 schrieb Tomasz Jeneralczyk:
> * gnu/packages/gtk.scm (gtk-pixbuf): Remove libx11 from native-inputs
> 
> gdk-pixbuf-xlib was split into its own library in gdk-pixbuf version
> 2.42.0:
> https://gitlab.gnome.org/GNOME/gdk-pixbuf/-/tags/2.42.0
Details go before, not after the ChangeLog.
> ---
>  gnu/packages/gtk.scm | 2 --
>  1 file changed, 2 deletions(-)
> 
> diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> index 4d6a690fbb..835c0be3a2 100644
> --- a/gnu/packages/gtk.scm
> +++ b/gnu/packages/gtk.scm
> @@ -682,8 +682,6 @@ (define-public gdk-pixbuf
>      (propagated-inputs
>       (list ;; Required by gdk-pixbuf-2.0.pc
>             glib
> -           ;; Required by gdk-pixbuf-xlib-2.0.pc
> -           libx11
>             ;; Used for testing and required at runtime.
>             shared-mime-info))
>      (inputs
This patch should go to core-updates, while 2/2 can go to master.
Tomasz Jeneralczyk June 28, 2022, 1:45 p.m. UTC | #2
On 2022-06-28 12:38, Liliana Marie Prikler wrote:
> This patch should go to core-updates, while 2/2 can go to master.

Should I send the patched here as [PATCH v2 1/2 core-updates] and [PATCH 
v2 2/2], or split it into two new patches?
Sorry, it's just not clear to me.

I also noticed I gave the 1/2 an incorrect changelog - it should be 
`propagated-inputs` instead of `native-inputs`. I'll fix that too.
Liliana Marie Prikler June 28, 2022, 1:49 p.m. UTC | #3
Am Dienstag, dem 28.06.2022 um 13:45 +0000 schrieb Tomasz Jeneralczyk:
> On 2022-06-28 12:38, Liliana Marie Prikler wrote:
> > This patch should go to core-updates, while 2/2 can go to master.
> 
> Should I send the patched here as [PATCH v2 1/2 core-updates] and
> [PATCH v2 2/2], or split it into two new patches?
> Sorry, it's just not clear to me.
The way you propose is *probably* fine.  It's rather rare that patches
"need" to be split in this manner.  FWIW I'd propose swapping the
patches around, so that [1/2] can go to master and [2/2] to core-
updates.

> I also noticed I gave the 1/2 an incorrect changelog - it should be 
> `propagated-inputs` instead of `native-inputs`. I'll fix that too.
Please do.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 4d6a690fbb..835c0be3a2 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -682,8 +682,6 @@  (define-public gdk-pixbuf
     (propagated-inputs
      (list ;; Required by gdk-pixbuf-2.0.pc
            glib
-           ;; Required by gdk-pixbuf-xlib-2.0.pc
-           libx11
            ;; Used for testing and required at runtime.
            shared-mime-info))
     (inputs