diff mbox series

[bug#43575] Gajim-Next

Message ID c9679efa-2900-a808-9f06-aa0a9ec55cb0@disroot.org
State Accepted
Headers show
Series [bug#43575] Gajim-Next | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Raghav Gururajan Sept. 23, 2020, 3:52 a.m. UTC
Hello Guix!

Please find the attached patch-set.

NOTES:
[1] New module gajim.scm was created, as Gajim project has quite a 
packages of it's own. The idea is similar to linphone.scm.
[2] Once users get used to gajim-next and gajim-omemo-next, we can 
deprecate older package definitions gajim and gajim-omemo.

Regards,
RG.
diff mbox series

Patch

From 178cecd9938328d075c8a2728d213cda17a19b95 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Tue, 22 Sep 2020 23:29:46 -0400
Subject: [PATCH 6/6] gnu: Add gajim-openpgp.

* gnu/packages/gajim.scm (gajim-openpgp): New variable.
---
 gnu/packages/gajim.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

diff --git a/gnu/packages/gajim.scm b/gnu/packages/gajim.scm
index a8df5b5840..2aa03d7a0f 100644
--- a/gnu/packages/gajim.scm
+++ b/gnu/packages/gajim.scm
@@ -24,6 +24,7 @@ 
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
+  #:use-module (gnu packages gnupg)
   #:use-module (gnu packages gstreamer)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages python)
@@ -182,4 +183,38 @@  Encryption to Gajim.")
     (home-page "https://dev.gajim.org/gajim/gajim-plugins/-/wikis/OmemoGajimPlugin")
     (license license:gpl3+)))
 
+(define-public gajim-openpgp
+  (package
+    (name "gajim-openpgp")
+    (version "1.3.5")
+    (source
+     (origin
+       (method url-fetch/zipbomb)
+       (uri
+        (string-append
+         "https://ftp.gajim.org/plugins_releases/openpgp_"
+         version ".zip"))
+       (sha256
+        (base32 "1jvpl2gjl5xxvsgxpmvh3mn2mm142dg2hknakkc32swb7l1fqx5m"))))
+    (build-system trivial-build-system)
+    (arguments
+     `(#:modules ((guix build utils))
+       #:builder
+       (begin
+         (use-modules (guix build utils))
+         (let* ((out (assoc-ref %outputs "out"))
+                (share (in-vicinity out "share/gajim/plugins"))
+                (source (assoc-ref %build-inputs "source")))
+           (mkdir-p share)
+           (copy-recursively source share)
+           #t))))
+    (propagated-inputs
+     `(("python-cryptography" ,python-cryptography)
+        ("python-gnupg" ,python-gnupg)))
+    (synopsis "Gajim OpenPGP Plugin")
+    (description "Gajim-OpenPGP is a plugin that adds support for the OpenPGP
+Encryption to Gajim.")
+    (home-page "https://dev.gajim.org/gajim/gajim-plugins/-/wikis/OpenPGPplugin")
+    (license license:gpl3+)))
+
 ;;; End of gajim.scm
-- 
2.28.0