From 88991ab20c81b86ae82ed9c7102d3cd163ee3f98 Mon Sep 17 00:00:00 2001
From: Giacomo Leidi <goodoldpaul@autistici.org>
Date: Mon, 2 Sep 2019 19:03:17 +0200
Subject: [PATCH] gnu: Add node-semver.
* gnu/packages/npm.scm: New file.
* gnu/local.mk: Add it.
* gnu/packages/npm.scm (node-semver): New variable.
---
gnu/local.mk | 2 ++
gnu/packages/npm.scm | 47 ++++++++++++++++++++++++++++++++++++++++++++
2 files changed, 49 insertions(+)
create mode 100644 gnu/packages/npm.scm
@@ -22,6 +22,7 @@
# Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
# Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
# Copyright © 2019 John Soo <jsoo1@asu.edu>
+# Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
#
# This file is part of GNU Guix.
#
@@ -354,6 +355,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/ninja.scm \
%D%/packages/node.scm \
%D%/packages/noweb.scm \
+ %D%/packages/npm.scm \
%D%/packages/nss.scm \
%D%/packages/ntp.scm \
%D%/packages/nutrition.scm \
new file mode 100644
@@ -0,0 +1,47 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages npm)
+ #:use-module (guix build-system node)
+ #:use-module (guix git-download)
+ #:use-module ((guix licenses) #:select (isc))
+ #:use-module (guix packages))
+
+(define-public node-semver
+ (package
+ (name "node-semver")
+ (version "6.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/npm/node-semver.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15xqmj5h1gz2p3v3gczjl07rm75miavqr70xw2fxgz3n880s4iyn"))))
+ (build-system node-build-system)
+ (arguments
+ `(;; FIXME: Tests depend on node-tap
+ #:tests? #f))
+ (home-page "https://github.com/npm/node-semver")
+ (synopsis "Parses semantic versions strings")
+ (description
+ "node-semver is a JavaScript implementation of the
+@uref{https://semver.org/, SemVer.org} specification.")
+ (license isc)))
--
2.23.0