diff mbox series

[bug#69359] gnu: osm2pgsql: Update to 1.11.0.

Message ID c8f59a81cf471961dcd407817a88eec3bfeefd8b.1708787701.git.felgru@posteo.net
State New
Headers show
Series [bug#69359] gnu: osm2pgsql: Update to 1.11.0. | expand

Commit Message

Felix Gruber Feb. 24, 2024, 3:15 p.m. UTC
* gnu/packages/geo.scm (osm2pgsql): Update to 1.11.0.
[arguments]: Look for proj API version 6 to use recent proj versions.
[inputs]: Remove proj-7; add cli11 and proj.

Change-Id: If1f14e5c675865d4485b16aca6146f555cc16d5e
---
 gnu/packages/geo.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)


base-commit: de24aaf13b17d6c019f3f240fd0eb0e1b8654970

Comments

Guillaume Le Vaillant Feb. 26, 2024, 10:52 a.m. UTC | #1
Patch applied as cc7486cd9840917b3e7d7e00cec1022179863784.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index aeb3a9fbd2..687effcace 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1677,7 +1677,7 @@  (define-public osmium-tool
 (define-public osm2pgsql
   (package
     (name "osm2pgsql")
-    (version "1.9.2")
+    (version "1.11.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1686,7 +1686,7 @@  (define-public osm2pgsql
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "198qcgl42pb8lk1bn41ncp8hc9gcg9k2p0ny42vak019w5l6jcj7"))
+                "135vqahlcrhwa3b9hfgbiqkzbbsjd4i79fp41cd0rp4zarcpi47p"))
               (modules '((guix build utils)))
               (snippet
                ;; Remove bundled libraries.
@@ -1694,20 +1694,21 @@  (define-public osm2pgsql
     (build-system cmake-build-system)
     (arguments
      (list #:tests? #f ;tests fail because we need to setup a database
-           #:configure-flags #~(list "-DUSE_PROJ_LIB=4" ;use API version 4
+           #:configure-flags #~(list "-DUSE_PROJ_LIB=6" ;use API version 6
                                      "-DWITH_LUAJIT=ON"
                                      "-DEXTERNAL_LIBOSMIUM=ON"
                                      "-DEXTERNAL_PROTOZERO=ON"
                                      "-DEXTERNAL_FMT=ON")))
     (inputs (list boost
                   bzip2
+                  cli11
                   expat
                   fmt-8
                   libosmium
                   luajit
                   nlohmann-json
                   postgresql
-                  proj-7
+                  proj
                   protozero
                   zlib))
     (native-inputs (list pandoc python python-argparse-manpage))