diff mbox series

[bug#70259,v2] gnu: evolution-data-server: Disable failing test on aarch64.

Message ID c8ef4332f306ef76328aebe2fcd329912ef92ad4.1712495942.git.roman@burningswell.com
State New
Headers show
Series [bug#70259,v2] gnu: evolution-data-server: Disable failing test on aarch64. | expand

Commit Message

Roman Scherer April 7, 2024, 1:23 p.m. UTC
* gnu/packages/gnome.scm (evolution-data-server): Disable failing test on aarch64.

Change-Id: Iccb75f2144b773a8b94242aaee9e6acedaa3af0b
---

Just after I fixed evolution-data-server-3.44, the evolution-data-server
packages also started to fail. This test is flaky on my aarch64 machine.

gnu/packages/gnome.scm | 6 ++++++
 1 file changed, 6 insertions(+)


base-commit: 12f02c9bb87b8ea756e5c09806522e6df8b7e1ca
prerequisite-patch-id: 0250f6d992ee74e81797cb1266771a825226fa0b
prerequisite-patch-id: e03a4f63a64eda0c1f229e0b92d130a9beadefa5
prerequisite-patch-id: 09e6b4e8c70f5eb7996f78194c59245f38d3241b
prerequisite-patch-id: a12882ccf5bbef1edbd1110f128cd107f84a1377
prerequisite-patch-id: 2c83a46f3bcf9d3e153e2543fe9a57e5f33af286
prerequisite-patch-id: 3c1ca4618ff254748694208007768994f8f3f180
prerequisite-patch-id: c6c55378dfbf74f5862c5b5609fe7cc3dc4b52d7
prerequisite-patch-id: 6307af77f1d5ccaef3accfce06479f604cdfd260
prerequisite-patch-id: 1f06621d95d4b22729a1461bca01feeb0d491324
prerequisite-patch-id: 2b5ca4e046c327f00c14fb9a0b7a08b6e4014bcb
prerequisite-patch-id: 7ebd64a45f6032d0fa2317d3b276cd93544ea187
prerequisite-patch-id: 6f659e1af6f034cd0f3541f605fa7c0f12845380
--
2.41.0

Comments

Christopher Baines April 15, 2024, 9:05 a.m. UTC | #1
Roman Scherer <roman@burningswell.com> writes:

> * gnu/packages/gnome.scm (evolution-data-server): Disable failing test on aarch64.
>
> Change-Id: Iccb75f2144b773a8b94242aaee9e6acedaa3af0b
> ---
>
> Just after I fixed evolution-data-server-3.44, the evolution-data-server
> packages also started to fail. This test is flaky on my aarch64 machine.
>
> gnu/packages/gnome.scm | 6 ++++++
>  1 file changed, 6 insertions(+)

Could you include the bit about the test being flaky in a comment, and
maybe also some information about how it fails (so that others can see
if they get a similar failure)?

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4934ade3dd..7a58c01e8c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8219,6 +8219,12 @@  (define-public evolution-data-server
                 "-DWITH_PHONENUMBER=ON"))
       #:phases
       #~(modify-phases %standard-phases
+          #$@(if (target-aarch64?)
+                   #~((add-after 'unpack 'disable-failing-aarch64-tests
+                        (lambda _
+                          (substitute* "tests/libebook/client/CMakeLists.txt"
+                            (("test-book-client-custom-summary") "")))))
+                   '())
           (add-after 'unpack 'disable-failing-tests
             (lambda _
               ;; tests/book-migration/test-migration.c:160:test_fetch_contacts: