diff mbox series

[bug#63524] gnu: cl-croatoan: Update to 0.1.

Message ID c896f1c44de4def3d468edf35809dfdeff6f7913.1684173126.git.cage-dev@twistfold.it
State New
Headers show
Series [bug#63524] gnu: cl-croatoan: Update to 0.1. | expand

Commit Message

cage May 15, 2023, 5:55 p.m. UTC
---
 gnu/packages/lisp-xyz.scm | 62 +++++++++++++++++++--------------------
 1 file changed, 30 insertions(+), 32 deletions(-)


base-commit: f0b4cfb475cd4a3c147a9ccb90ddb3610df1954b
--
2.34.0

Comments

Guillaume Le Vaillant May 17, 2023, 1:33 p.m. UTC | #1
Patch applied as ed60a524fbb34b0b37799c556f2516c06d050af3.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 8bed746669..c8e8cd47e3 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -18512,39 +18512,37 @@  (define-public cl-tooter
   (sbcl-package->cl-source-package sbcl-tooter))

 (define-public sbcl-croatoan
-  (let ((commit "42e474f4dffe2f4e429905a612be5736c2c3e374")
-        (revision "7"))
-    (package
-      (name "sbcl-croatoan")
-      (version (git-version "0.0.1" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/McParen/croatoan")
-               (commit commit)))
-         (file-name (git-file-name "cl-croatoan" version))
-         (sha256
-          (base32 "12hnj8gwk2600j3kn778xvvpx3y6z0428v5dq2qbf4vbzj66vcxj"))))
-      (build-system asdf-build-system/sbcl)
-      (arguments
-       '(#:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'fix-paths
-             (lambda* (#:key inputs #:allow-other-keys)
-               (substitute* "ncurses/ncurses.lisp"
-                 (("libncursesw.so")
-                  (search-input-file inputs "/lib/libncursesw.so"))))))))
-      (inputs
-       (list ncurses
-             sbcl-cffi
-             sbcl-trivial-gray-streams
-             sbcl-bordeaux-threads))
-      (synopsis "Common Lisp bindings for the ncurses terminal library")
-      (description "Croatoan provides high-level Common Lisp CLOS bindings for
+  (package
+    (name "sbcl-croatoan")
+    (version "0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/McParen/croatoan")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name "cl-croatoan" version))
+       (sha256
+        (base32 "1whbvwc4df7zz0002xy3aczrpf4s3vk6kmyh9wydgwl112h060pd"))))
+    (build-system asdf-build-system/sbcl)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-paths
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "ncurses/ncurses.lisp"
+               (("libncursesw.so")
+                (search-input-file inputs "/lib/libncursesw.so"))))))))
+    (inputs
+     (list ncurses
+           sbcl-cffi
+           sbcl-trivial-gray-streams
+           sbcl-bordeaux-threads))
+    (synopsis "Common Lisp bindings for the ncurses terminal library")
+    (description "Croatoan provides high-level Common Lisp CLOS bindings for
 the ncurses terminal library.")
-      (home-page "https://github.com/McParen/croatoan")
-      (license license:expat))))
+    (home-page "https://github.com/McParen/croatoan")
+    (license license:expat)))

 (define-public ecl-croatoan
   (sbcl-package->ecl-package sbcl-croatoan))