diff mbox series

[bug#55575] gnu: Add archivebox.

Message ID c87ce9f8b812cc8a871f6de7397970f8af26d5bd.camel@courrier.dev
State Accepted
Headers show
Series [bug#55575] gnu: Add archivebox. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Pradana Adrinusa AUMARS May 22, 2022, 1:30 p.m. UTC
From 597e0ee3e2073cc3bbf2a8a997fcbeef750b9f98 Mon Sep 17 00:00:00 2001
From: Pradana AUMARS <paumars@courrier.dev>
Date: Sun, 22 May 2022 15:27:02 +0200
Subject: [PATCH] gnu: Add archivebox.

* gnu/packages/web.scm (archivebox): New variable.
---
 gnu/packages/web.scm | 44 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)

Comments

Pradana Adrinusa AUMARS May 22, 2022, 1:33 p.m. UTC | #1
This patch requires python-django-3.1.14, which is added in patch
bug#54187, so the latter would need to be admitted in first.
Ludovic Courtès May 23, 2022, 2:23 p.m. UTC | #2
Hi,

Pradana Adrinusa AUMARS <paumars@courrier.dev> skribis:

>>From 597e0ee3e2073cc3bbf2a8a997fcbeef750b9f98 Mon Sep 17 00:00:00 2001
> From: Pradana AUMARS <paumars@courrier.dev>
> Date: Sun, 22 May 2022 15:27:02 +0200
> Subject: [PATCH] gnu: Add archivebox.
>
> * gnu/packages/web.scm (archivebox): New variable.

[...]

> +   (synopsis "Open source self-hosted web archiving")

I removed “Open source” (everything is free software in Guix, no need to
be explicit) and applied it.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 600ef0c895..72b78b4d43 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -56,6 +56,7 @@ 
 ;;; Copyright © 2021 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2022 cage <cage-dev@twistfold.it>
+;;; Copyright © 2022 Pradana Aumars <paumars@courrier.dev>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -112,6 +113,7 @@  (define-module (gnu packages web)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages cyrus-sasl)
   #:use-module (gnu packages databases)
+  #:use-module (gnu packages django)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages emacs)
@@ -154,6 +156,7 @@  (define-module (gnu packages web)
   #:use-module (gnu packages markup)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages networking)
+  #:use-module (gnu packages node)
   #:use-module (gnu packages nss)
   #:use-module (gnu packages openldap)
   #:use-module (gnu packages openstack)
@@ -162,6 +165,8 @@  (define-module (gnu packages web)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages perl-check)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-build)
+  #:use-module (gnu packages python-check)
   #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
@@ -177,7 +182,9 @@  (define-module (gnu packages web)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages valgrind)
   #:use-module (gnu packages version-control)
+  #:use-module (gnu packages video)
   #:use-module (gnu packages vim)
+  #:use-module (gnu packages wget)
   #:use-module (gnu packages xml)
   #:use-module ((srfi srfi-1) #:select (delete-duplicates)))
 
@@ -8218,3 +8225,40 @@  (define-public quark
       ;; "cpe:2.3:a:comelz:quark" package.  The proper fix is for (guix cve)
       ;; to account for "vendor names".
       (properties '((lint-hidden-cve . ("CVE-2019-15520")))))))
+
+(define-public archivebox
+  (package
+   (name "archivebox")
+   (version "0.6.2")
+   (source (origin
+            (method url-fetch)
+            (uri (pypi-uri name version))
+            (sha256
+             (base32
+              "1mnq82ynq01l7vx957bbx4bvgwdh59qsnx6pdydaqszbakp74yyc"))))
+   (build-system python-build-system)
+   (propagated-inputs
+    (list curl
+          node))
+   (inputs
+    (list python
+          youtube-dl
+          wget
+          git
+          python-w3lib
+          python-ipython
+          python-croniter
+          python-crontab
+          python-dateparser
+          python-django-extensions
+          python-django-3.1.14
+          python-mypy-extensions))
+   (native-inputs
+    (list python-wheel))
+   (synopsis "Open source self-hosted web archiving")
+   (description "ArchiveBox is a powerful, self-hosted internet archiving
+solution to collect, save, and view sites you want to preserve offline.
+You can feed it URLs one at a time, or schedule regular imports.  It saves
+snapshots of the URLs you feed it in several formats.")
+   (home-page "https://archivebox.io/")
+   (license license:expat)))