diff mbox series

[bug#36824] gnu: Add oshu.

Message ID c86bdb6f-840f-6b6a-e600-6c24d8c22806@cs.ru.nl
State Accepted
Headers show
Series [bug#36824] gnu: Add oshu. | expand

Commit Message

Dan Frumin July 29, 2019, 11:32 a.m. UTC
Hi Tobias,

Thank you for your timely reply.

(As a side note, can you please CC the messages to me, because I am not subscribed to the guix-patches mailing list. Maybe I am using debbugs in some 
wrong way).

 > I'd rather see a 'first-class' description of what this game is
 > and does and drop the 'is a clone of' part entirely: 'is capable
 > of playing the original Osu! beatmaps' already says it all without
 > implying it's some kind of knock-off ;-)

That's a good point. I changed the description to something more appropriate.

 > s/videocard/video card/, or graphics card.  Is it really tied to
 > the kernel?  (Not entirely implausible considering the real-time
 > audio nature.  Interesting design, by the way.)

Oops, I didn't mean to say that it's tied to the Linux kernel (although I don't think it's developed/tested on other platforms). I just wanted to 
contrast that with the old original Osu! game which is for Windows.

 > Could we package these separately?  How are they licenced?

I am not sure. You basically have to download them manually from the Osu! website or from other places on the web.
I don't think they are licensed very well at all..


 > Ugh, no licence headers?  I guess that does make it GPL 3-only,
 > but I'm no expert.

Yeah I am not sure about the headers, but the COPYING file indicates that it's GPL 3

Best,
Dan

Comments

Ricardo Wurmus July 29, 2019, 1:20 p.m. UTC | #1
Dan Frumin <dfrumin@cs.ru.nl> writes:

>  > Ugh, no licence headers?  I guess that does make it GPL 3-only,
>  > but I'm no expert.
>
> Yeah I am not sure about the headers, but the COPYING file indicates that it's GPL 3

Here are more details:

    https://github.com/fmang/oshu/blob/30b316173aca8fd6b2dce8b7d425845241ae5f13/src/oshu/main.cc#L69

The license is GPL version 3 or later.
guix--- via Guix-patches via July 29, 2019, 1:29 p.m. UTC | #2
Ricardo,

Ricardo Wurmus 写道:
> Dan Frumin <dfrumin@cs.ru.nl> writes:
>
>>  > Ugh, no licence headers?  I guess that does make it GPL 
>>  > 3-only,
>>  > but I'm no expert.
>>
>> Yeah I am not sure about the headers, but the COPYING file 
>> indicates that it's GPL 3
>
> Here are more details:
>
>     https://github.com/fmang/oshu/blob/30b316173aca8fd6b2dce8b7d425845241ae5f13/src/oshu/main.cc#L69
>
> The license is GPL version 3 or later.

Thanks!  I opened about 5 files at random through the Web interfac 
but not the right one…

Kind regards,

T G-R
diff mbox series

Patch

From e54fb4dca4988747c5c41a1081d25cdae524dd55 Mon Sep 17 00:00:00 2001
From: Dan Frumin <dfrumin@cs.ru.nl>
Date: Sat, 27 Jul 2019 20:18:22 +0200
Subject: [PATCH] gnu: Add oshu.

---
 gnu/packages/games.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a17ac9728c..78b951b702 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6374,6 +6374,41 @@  to download and install them in @file{$HOME/.stepmania-X.Y/Songs} directory.")
     (home-page "https://www.stepmania.com")
     (license license:expat)))
 
+(define-public oshu
+  (package
+    (name "oshu")
+    (version "2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/fmang/oshu.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "01w1x46hh36idjl94xd18dwppp0y30qxmb498gp7hnjzy205q6rw"))))
+    (build-system cmake-build-system)
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("sdl2" ,sdl2)
+              ("sdl2-image" ,sdl2-image)
+              ("ffmpeg" ,ffmpeg)
+              ("cairo" ,cairo)
+              ("pango" ,pango)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; `make test' doesn't actually build the test executable
+         (add-before 'check 'zerotokei
+           (lambda _ (invoke "make" "zerotokei"))))))
+    (home-page "https://github.com/fmang/oshu/")
+    (synopsis "Rhythm game in which you click on circles")
+    (description "Oshu! is a free clone of the Osu! rhythm game, designed to
+be run on GNU/Linux without requiring a powerful graphics card.  Oshu! is
+capable of playing the original Osu! beatmaps (not included in this
+package). ")
+    (license license:gpl3)))
+
 (define-public btanks
   (package
     (name "btanks")
-- 
2.17.1