diff mbox series

[bug#72474,01/30] gnu: Add erlang-base64url.

Message ID c8325d72384868497866fe5ddff2a576e130272b.1722851684.git.igor@goryachev.org
State New
Headers show
Series Add ejabberd package. | expand

Commit Message

Igor Goryachev Aug. 5, 2024, 10:44 a.m. UTC
* gnu/packages/erlang-xyz.scm (erlang-base64url): New variable.

Change-Id: I2b7b44631408138576e4a1498a39c64810cb0582
---
 gnu/packages/erlang-xyz.scm | 51 +++++++++++++++++++++++++++++++++++++
 1 file changed, 51 insertions(+)
 create mode 100644 gnu/packages/erlang-xyz.scm
diff mbox series

Patch

diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
new file mode 100644
index 0000000000..1cf5d9c6fd
--- /dev/null
+++ b/gnu/packages/erlang-xyz.scm
@@ -0,0 +1,51 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Igor Goryachev <igor@goryachev.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages erlang-xyz)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages erlang)
+  #:use-module (guix build-system rebar)
+  #:use-module (guix download)
+  #:use-module (guix gexp)
+  #:use-module (guix git-download)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix utils))
+
+(define-public erlang-base64url
+  (package
+    (name "erlang-base64url")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri "base64url" version))
+       (sha256
+        (base32 "0p4zf53v86zfpnk3flinjnk6cx9yndsv960386qaj0hsfgaavczr"))))
+    (build-system rebar-build-system)
+    (synopsis "URL safe base64-compatible codec")
+    (description "This package provides URL safe base64-compatible codec
+for Erlang.")
+    (home-page "https://hex.pm/packages/base64url")
+    (license license:expat)))
+
+;;;
+;;; Avoid adding new packages to the end of this file. To reduce the chances
+;;; of a merge conflict, place them above by existing packages with similar
+;;; functionality or similar names.
+;;;