diff mbox series

[bug#52524,2]

Message ID c82a34a9-7eec-3146-38e3-69a62d450d83@cock.li
State Accepted
Headers show
Series [bug#52524,2] | expand

Commit Message

Justin Veilleux Dec. 15, 2021, 9:46 p.m. UTC
Sorry, in the previous patch, I forgot to wrap `qdirstat-cache-writer`

Here is the updated version.

Comments

Leo Famulari Dec. 16, 2021, 5:43 a.m. UTC | #1
On Wed, Dec 15, 2021 at 04:46:59PM -0500, Justin Veilleux wrote:
> Here is the updated version.

> From 31aad60271fd58a300513cf14cfef5664139de37 Mon Sep 17 00:00:00 2001
> From: terramorpha <terramorpha@cock.li>
> Date: Wed, 15 Dec 2021 16:21:06 -0500
> Subject: [PATCH] gnu: Add qdirstat.
> 
> * gnu/packages/disk.scm (qdirstat): New variable

Thanks! I pushed as 6335c94b1d9897b6f65234f6d266c0c0f36d6112, after
making these changes:

* Cosmetic changes to indentation

* Fixed a spelling mistake:
> +    (synopsis "Storage utilisation vizualization tool")
                                        ^                    
			              visualization

* Corrected the issues reported by `guix lint`. Specifically, I
added a file-name field to the origin, and I added bash-minimal to the
inputs, since it will be referred to by the wrapper. The latter change
matters when cross-compiling:

https://git.savannah.gnu.org/cgit/guix.git/commit/?id=eac82c0e0a9f5afb5452928acf9b84cbc019c81c
diff mbox series

Patch

From 31aad60271fd58a300513cf14cfef5664139de37 Mon Sep 17 00:00:00 2001
From: terramorpha <terramorpha@cock.li>
Date: Wed, 15 Dec 2021 16:21:06 -0500
Subject: [PATCH] gnu: Add qdirstat.

* gnu/packages/disk.scm (qdirstat): New variable
---
 gnu/packages/disk.scm | 47 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 47 insertions(+)

diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index d74d941ee0..79cf0e36ea 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -21,6 +21,7 @@ 
 ;;; Copyright © 2021 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
 ;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -66,10 +67,12 @@  (define-module (gnu packages disk)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages nss)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages perl-web)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages popt)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages samba)
   #:use-module (gnu packages serialization)
@@ -1330,3 +1333,47 @@  (define-public duc
 Duc comes with console utilities, ncurses and X11 user interfaces and a CGI
 wrapper for disk usage querying and visualisation.")
     (license license:lgpl3+)))
+
+(define-public qdirstat
+  (package
+    (name "qdirstat")
+    (version "1.8")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/shundhammer/qdirstat")
+                    (commit version)))
+              (sha256
+               (base32
+                "079rmy3j0442y5gjh6la6w1j6jaw83wklamrf19yxi20zsm99xs7"))))
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'configure
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (system* "qmake"
+                               (string-append "INSTALL_PREFIX="
+                                              (assoc-ref outputs "out")))))
+                  (add-after 'install 'wrap
+                    (lambda* (#:key inputs outputs #:allow-other-keys)
+                      (wrap-program (string-append
+                                     (assoc-ref outputs "out")
+                                     "/bin/qdirstat-cache-writer")
+                        `("PERL5LIB" ":" prefix
+                          (,(string-append
+                             (assoc-ref inputs "perl-uri-escape")
+                             "/lib/perl5/site_perl")))))))))
+    (build-system gnu-build-system)
+    (inputs
+     (list
+      perl
+      perl-uri-escape
+      qtbase-5
+      zlib))
+    (synopsis "Storage utilisation vizualization tool")
+    (description
+     "QDirStat is a graphical application to show where your disk space has
+gone and to help you to clean it up.")
+
+    (home-page "https://github.com/shundhammer/qdirstat")
+    (license license:gpl2)))
+
-- 
2.34.0