diff mbox series

[bug#72173] gnu: chicken: Update to 5.4.0.

Message ID c8026dbdaa7d837ed8d471d22ecd90954ccb692d.1721293178.git.ashish.is@lostca.se
State New
Headers show
Series [bug#72173] gnu: chicken: Update to 5.4.0. | expand

Commit Message

kiasoc5--- via Guix-patches via July 18, 2024, 8:59 a.m. UTC
From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/chicken.scm (chicken): Update to 5.4.0.

Change-Id: I448bdc25a5cb11e55c7ebb9d9e0cf1876ca958d8
---
 gnu/packages/chicken.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)


base-commit: ee7e5e00bf2b9257e67d785b37efddb008c5da37

Comments

jgart July 19, 2024, 9:47 p.m. UTC | #1
Applied, thanks!
Ludovic Courtès July 20, 2024, 1:53 p.m. UTC | #2
Hey jgart & Ashish,

ashish.is@lostca.se skribis:

> From: Ashish SHUKLA <ashish.is@lostca.se>
>
> * gnu/packages/chicken.scm (chicken): Update to 5.4.0.
>
> Change-Id: I448bdc25a5cb11e55c7ebb9d9e0cf1876ca958d8

This caused a number of Chicken packages to fail to build:

  https://ci.guix.gnu.org/eval/1498240?status=newly-failed

In particular, ‘chicken-compile-file’ fails to build with:

--8<---------------cut here---------------start------------->8---
starting phase `build'

Error: extension or version not found: "compile-file"
fetching compile-file
TCP connect timeout
TCP connect timeout
error: in phase 'build': uncaught exception:
%exception #<&invoke-error program: "chicken-install" arguments: ("-cached" "-no-install" "compile-file") exit-status: 70 term-signal: #f stop-signal: #f> 
phase `build' failed after 0.0 seconds
--8<---------------cut here---------------end--------------->8---

(From <https://ci.guix.gnu.org/build/5185638/details>.)

Could you take a look?

Thanks,
Ludo’.
jgart July 20, 2024, 3:43 p.m. UTC | #3
July 20, 2024 at 8:53 AM, "Ludovic Courtès" <ludo@gnu.org> wrote:

Hi Ludo,

Sorry, I forgot to check the dependent chicken packages 🙃🦆

I will revert this commit immediately on Monday when I get back.

I don't think I'll have time to look into the chicken package failures this weekend or next week.

ashish, could you send a v2 with the dependent chicken packages passing in order for this to be merged properly by Monday?

all the best,

jgart
jgart July 22, 2024, 4:04 p.m. UTC | #4
Hi all,

I've reverted this commit for now.

Hi ashish,

Feel free to send a v2 including the build passing dependents.

If you'd like to me to review it again please Cc me.
Ashish SHUKLA July 22, 2024, 9:08 p.m. UTC | #5
On Mon, Jul 22, 2024 at 11:04:18AM -0500, jgart wrote:
> 
> Hi all,
> 
> I've reverted this commit for now.
> 
> Hi ashish,
> 
> Feel free to send a v2 including the build passing dependents.
> 
> If you'd like to me to review it again please Cc me.
> -- 
> all the best,
> jgart

Sorry about the lack of proper testing, and lack of timely follow up on 
my part. I'll work on a fix sometime this week, and will get back to 
you.

Apologies again.
jgart July 22, 2024, 9:34 p.m. UTC | #6
> Sorry about the lack of proper testing, and lack of timely follow up on 
> 
> my part. I'll work on a fix sometime this week, and will get back to 
> 
> you.
> 
> Apologies again.

No worries and thanks for contributing.

Keep us posted on the new version. 

I can review and test again once ready.

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/chicken.scm b/gnu/packages/chicken.scm
index 8f5e8ce98d..d48a0c89c0 100644
--- a/gnu/packages/chicken.scm
+++ b/gnu/packages/chicken.scm
@@ -33,14 +33,14 @@  (define-module (gnu packages chicken)
 (define-public chicken
   (package
     (name "chicken")
-    (version "5.3.0")
+    (version "5.4.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://code.call-cc.org/releases/"
                                   version "/chicken-" version ".tar.gz"))
               (sha256
                (base32
-                "0xhdvcdwlv9vbhxh7k0fzd32ybhc7fn83y9fj48dhzp1z7c9kbf3"))))
+                "0pzcrnzkjw2sa44vy59wbygvlc3nva8zisprkdnvyrqi3jk4lp9w"))))
     (build-system gnu-build-system)
     (arguments
      `(#:modules ((guix build gnu-build-system)