diff mbox series

[bug#47869,v4,core-updates] various cross-compilation fixes in guix/build/utils.scm

Message ID c7e4fc629adaf7c44f618cfdb38c05d34cb5aec4.camel@telenet.be
State Accepted
Headers show
Series [bug#47869,v4,core-updates] various cross-compilation fixes in guix/build/utils.scm | expand

Commit Message

M June 2, 2021, 7:56 a.m. UTC
Hi guix,

This is version 4 of the patch series.
It lets 'search-input-file' raise the new
&search-error exception instead of misc-error.

The documentation of 'search-input-file' has been
adjusted to give an example of how it can be used.

Also, there is one new test in tests/build-utils.scm
("search-input-file: can search in multiple directories").

Greetings,
Maxime.

Comments

Ludovic Courtès June 4, 2021, 9:31 p.m. UTC | #1
Hi Maxime,

Maxime Devos <maximedevos@telenet.be> skribis:

> This is version 4 of the patch series.
> It lets 'search-input-file' raise the new
> &search-error exception instead of misc-error.
>
> The documentation of 'search-input-file' has been
> adjusted to give an example of how it can be used.
>
> Also, there is one new test in tests/build-utils.scm
> ("search-input-file: can search in multiple directories").

I pushed the whole series as d1827d5c636adb395153a4ed6064629ed5b7664b:

  d1827d5c63 * gnu: wireguard-tools: Set #:sh argument of 'wrap-program'.
  96a2ae40fb * gnu: protonvpn-cli: Set #:sh argument of 'wrap-program'.
  b74085ce36 * gnu: openconnect-sso: Set #:sh argument of 'wrap-program'.
  3bbb0ec888 * gnu: vpnc-scripts: Set #:guile argument of 'wrap-script'.
  a4e38cc216 * gnu: clipmenu: Set #:guile argument of 'wrap-script'.
  0758ee8002 * gnu: sieve-connect: Set #:guile argument of 'wrap-script'.
  b2459387b9 * gnu: nanopolish: Set #:guile argument of 'wrap-script'.
  2d092a2afa * gnu: gess: Set #:guile argument of 'wrap-script'.
  c4989f7569 * gnu: prinseq: Set #:guile argument of 'wrap-script'.
  fadbac0ecc * gnu: proteinortho: Set #:guile argument of 'wrap-script'.
  b202fdf131 * gnu: bats: Set #:guile argument of 'wrap-script'.
  0a843e3643 * gnu: carla: Set #:guile argument of 'wrap-script'.
  a62d17dc05 * rakudo-build-system: Look up the interpreter in 'inputs'.
  2ac898d7f8 * qt-build-system: Look up the interpreter in 'inputs'.
  5b24cbee31 * python-build-system: Look up the interpreter in 'inputs'.
  1dbc3b2b0c * glib-or-gtk-build-system: Look up the interpreter in 'inputs'.
  5378edeab4 * utils: Define ‘search-input-file’ procedure.
  8b0899963f * utils: Allow overriding the shell interpreter in ‘wrap-program’.

Thank you!

Ludo’.
diff mbox series

Patch

From 00a73e18e1b62ec525a44cbe890843f1c93b9d16 Mon Sep 17 00:00:00 2001
From: Maxime Devos <maximedevos@telenet.be>
Date: Mon, 31 May 2021 20:12:55 +0200
Subject: [PATCH 18/18] gnu: wireguard-tools: Set #:sh argument of
 'wrap-program'.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/vpn.scm
  (wireguard-tools)[arguments]<#:phases>{wrap-wg-quick}:
  Set #:sh argument of ‘wrap-program’.
---
 gnu/packages/vpn.scm | 1 +
 1 file changed, 1 insertion(+)

diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 66c103e75f..34715a4cc8 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -726,6 +726,7 @@  WireGuard was added to Linux 5.6.")
                    (coreutils (string-append (assoc-ref inputs "coreutils")
                                              "/bin")))
                (wrap-program (string-append out "/bin/wg-quick")
+                 #:sh (search-input-file inputs "bin/bash")
                  `("PATH" ":" prefix ,(append inputs-sbin
                                               (list coreutils))))
                #t))))))
-- 
2.31.1