diff mbox series

[bug#69526,v2,08/10] gnu: Add rust-hickory-client-0.24.

Message ID c7de65bb4fba9e63f16db3607ee5b0fff93737b2.1709594359.git.~@wolfsden.cz
State New
Headers show
Series [bug#69526,v2,01/10] gnu: Add rust-h3-0.0.2. | expand

Commit Message

Tomas Volf March 4, 2024, 11:19 p.m. UTC
* gnu/packages/crates-web.scm (rust-hickory-client-0.24): New variable.

Change-Id: I0fcaf5d82837d2d380171faae0bcddd281e55826
---
v2: Move to -web.

 gnu/packages/crates-web.scm | 39 +++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

--
2.41.0
diff mbox series

Patch

diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index 05f2f98a58..53d97db1c3 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -2113,6 +2113,45 @@  (define-public rust-h3-quinn-0.0.3
                        ("rust-quinn-proto" ,rust-quinn-proto-0.10)
                        ("rust-tokio-util" ,rust-tokio-util-0.7))))))

+(define-public rust-hickory-client-0.24
+  (package
+    (name "rust-hickory-client")
+    (version "0.24.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "hickory-client" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0bj6g69h86d7mbclrwaj7cgl1plr6pvllv8qn69xmpgh9h90hgkz"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-cfg-if" ,rust-cfg-if-1)
+                       ("rust-data-encoding" ,rust-data-encoding-2)
+                       ("rust-futures-channel" ,rust-futures-channel-0.3)
+                       ("rust-futures-util" ,rust-futures-util-0.3)
+                       ("rust-hickory-proto" ,rust-hickory-proto-0.24)
+                       ("rust-once-cell" ,rust-once-cell-1)
+                       ("rust-radix-trie" ,rust-radix-trie-0.2)
+                       ("rust-rand" ,rust-rand-0.8)
+                       ("rust-rustls" ,rust-rustls-0.21)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-thiserror" ,rust-thiserror-1)
+                       ("rust-tokio" ,rust-tokio-1)
+                       ("rust-tracing" ,rust-tracing-0.1))))
+    (home-page "https://hickory-dns.org/")
+    (synopsis
+     "Client library for Hickory DNS, with DNSSEC support")
+    (description
+     "Hickory DNS is a safe and secure DNS library.  This is the Client
+library with DNSSEC support.  DNSSEC with NSEC validation for negative
+records, is complete.  The client supports dynamic DNS with SIG0 authenticated
+requests, implementing easy to use high level funtions.  Hickory DNS is based
+on the Tokio and Futures libraries, which means it should be easily integrated
+into other software that also use those libraries.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-hickory-proto-0.24
   (package
     (name "rust-hickory-proto")