diff mbox series

[bug#42282] gnu: Add ttaenc.

Message ID c7890e12e96eea0313dbd06136d7ae09b725642c.camel@zrythm.org
State Accepted
Headers show
Series [bug#42282] gnu: Add ttaenc. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou July 8, 2020, 9:44 p.m. UTC
Hi,

This patch adds the TTA encoder.

Thanks,
Alex

Comments

Marius Bakke July 20, 2020, 10:40 p.m. UTC | #1
Alexandros Theodotou <alex@zrythm.org> writes:

> Hi,
>
> This patch adds the TTA encoder.

[...]

> * gnu/packages/audio.scm (ttaenc): New variable.

[...]
  
> +(define-public ttaenc
> +  (package
> +    (name "ttaenc")
> +    (version "3.4.1")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (string-append "mirror://sourceforge/tta/"
> +                            "tta/ttaenc-src"
> +                            "/ttaenc-" version "-src.tgz"))
> +        (sha256
> +          (base32
> +            "1iixpr4b89g9g1hwn8ak8k8iflcww3r5f09a117qdidc2nqcijdj"))))

If you don't use Emacs, please run ./etc/indent-code.el before
submitting packages.  :-)

> +    (build-system gnu-build-system)
> +    (arguments
> +     `(#:make-flags
> +       (list "CC=gcc" (string-append "INSDIR=" (assoc-ref %outputs "out") "/bin"))

I used (string-append "CC=" ,(cc-for-target)) here to aid
cross-compilation.

> +       #:phases
> +       (modify-phases %standard-phases
> +         (delete 'configure) ; no configure
> +         (delete 'check)     ; no check

And added #:tests? #f instead of deleting the phase.

> +        (add-before 'install 'make-bindir
> +          (lambda* (#:key outputs #:allow-other-keys)
> +            (let* ((out (assoc-ref outputs "out")))
> +              (mkdir-p (string-append out "/bin"))
> +              #t))))))
> +    (synopsis "TTA lossless audio encoder")
> +    (description
> +      "TTA performs lossless compression on multichannel 8,16 and 24 bits
> +data of the Wav audio files.  Being lossless means that no data-
> +quality is lost in the compression - when uncompressed, the data will
> +be identical to the original.  The compression ratios of TTA depend on
> +the type of music file being compressed, but the compression size
> +will generally range between 30% - 70% of the original.  TTA format
> +supports both of ID3v1/v2 and APEv2 tags. Detailed format description
> +is available at http://tta.sourceforge.net")

I removed the last sentence, because that URL just redirects to the home
page and did not actually contain a detailed format description.  Also,
it was missing punctuation, and lacked two spaces after the previous
punctuation (did you forget to use 'guix lint'?).

> +    (home-page "http://tausoft.org/")
> +    (license license:gpl2)))

This is GPL2+, as explicitly stated in the README.

Applied with those changes, thanks!
diff mbox series

Patch

From cd611e07a71f743d1e71d695c2a48c53e906fc0c Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Jul 2020 22:43:14 +0100
Subject: [PATCH] gnu: Add ttaenc.

* gnu/packages/audio.scm (ttaenc): New variable.
---
 gnu/packages/audio.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 8fc23825ea..97264e5592 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4003,6 +4003,45 @@  stream to one or more IceCast and/or ShoutCast servers.")
     (home-page "https://x42.github.io/libltc/")
     (license license:lgpl3+)))
 
+(define-public ttaenc
+  (package
+    (name "ttaenc")
+    (version "3.4.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "mirror://sourceforge/tta/"
+                            "tta/ttaenc-src"
+                            "/ttaenc-" version "-src.tgz"))
+        (sha256
+          (base32
+            "1iixpr4b89g9g1hwn8ak8k8iflcww3r5f09a117qdidc2nqcijdj"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags
+       (list "CC=gcc" (string-append "INSDIR=" (assoc-ref %outputs "out") "/bin"))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure) ; no configure
+         (delete 'check)     ; no check
+        (add-before 'install 'make-bindir
+          (lambda* (#:key outputs #:allow-other-keys)
+            (let* ((out (assoc-ref outputs "out")))
+              (mkdir-p (string-append out "/bin"))
+              #t))))))
+    (synopsis "TTA lossless audio encoder")
+    (description
+      "TTA performs lossless compression on multichannel 8,16 and 24 bits
+data of the Wav audio files.  Being lossless means that no data-
+quality is lost in the compression - when uncompressed, the data will
+be identical to the original.  The compression ratios of TTA depend on
+the type of music file being compressed, but the compression size
+will generally range between 30% - 70% of the original.  TTA format
+supports both of ID3v1/v2 and APEv2 tags. Detailed format description
+is available at http://tta.sourceforge.net")
+    (home-page "http://tausoft.org/")
+    (license license:gpl2)))
+
 (define-public redkite
   (package
     (name "redkite")
-- 
2.27.0