diff mbox series

[bug#74411,2/4] gnu: Add dictd-1.13.1.

Message ID c75dcb1d968391132b2e593a91ca3e7c376569a7.1731747114.git.runciter@whispers-vpn.org
State New
Headers show
Series Add DICT and FreeDict projects packages | expand

Commit Message

Runciter Nov. 18, 2024, 5:56 a.m. UTC
* gnu/packages/dictd.scm (dictd-1.13.1): New variable.

Signed-off-by: Runciter <runciter@whispers-vpn.org>
---
 gnu/packages/dictd.scm | 39 ++++++++++++++++++++++++++++++++++++++-
 1 file changed, 38 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/dictd.scm b/gnu/packages/dictd.scm
index fed41def64..732f2bb6cc 100644
--- a/gnu/packages/dictd.scm
+++ b/gnu/packages/dictd.scm
@@ -23,7 +23,10 @@  (define-module (gnu packages dictd)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
-  #:use-module (gnu packages autotools))
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages bison)
+  #:use-module (gnu packages flex)
+  #:use-module (gnu packages compression))
 
 (define-public libmaa-1.3.2
   (package
@@ -59,3 +62,37 @@  (define-public libmaa-1.3.2
 the performance of memory-intensive applications.")
     (home-page "https://sourceforge.net/projects/dict/")
     (license gpl2+)))
+
+(define-public dictd-1.13.1
+  (package
+    (name "dictd")
+    (version "1.13.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/dict/dictd/"
+                           "dictd-"
+                           version
+                           "/dictd-"
+                           version
+                           ".tar.gz"))
+       (sha256
+        (base32 "06racmv25ihwgwf67fgj2703ik0m5i2cjzcxasa88kc92rysdwg4"))))
+    (inputs (list libmaa-1.3.2 zlib))
+    (native-inputs (list libtool bison flex))
+    (arguments
+     (list
+      #:test-target "test"))
+    (build-system gnu-build-system)
+    (synopsis "@command{dict}, @command{dictd} and @command{dictfmt} programs")
+    (description
+     "The DICT Interchange Format (DICF) is a human-readable
+ format for the interchange of dictionary databases for the use with
+DICT protocol client/server software.
+
+This package provides a client @command{dict} and a server program
+@command{dictd} for the DICT protocol, as well as a utility
+@command{dictfmt} to convert various dictionary formats into
+dictionaries that can be served by @command{dictd} or @command{dicos}")
+    (home-page "https://sourceforge.net/projects/dict/")
+    (license gpl2+)))