diff mbox series

[bug#63645] gnu: swaynotificationcenter: Update to 0.8.0

Message ID c734e5135bf527b91c800d1296e777615c24ac26.1684765256.git.bjc@spork.org
State New
Headers show
Series [bug#63645] gnu: swaynotificationcenter: Update to 0.8.0 | expand

Commit Message

Brian Cully May 22, 2023, 2:20 p.m. UTC
* gnu/packages/wm.scm (swaynotificationcenter): Update to 0.8.0.
---
 gnu/packages/wm.scm | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)


base-commit: 849286ba66c96534bddc04df1a47d5692cbc977e
prerequisite-patch-id: 18557da18beab5677060ea1de1897768791ce89e
prerequisite-patch-id: a2d8b917b767b5445112f49ca4d9b060e8baa587
prerequisite-patch-id: eabe444a8c70abebec53c814fbd88236bb86fabf

Comments

Christopher Baines June 12, 2023, 6:38 p.m. UTC | #1
Brian Cully via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/wm.scm (swaynotificationcenter): Update to 0.8.0.
> ---
>  gnu/packages/wm.scm | 11 ++++++++---
>  1 file changed, 8 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 4360f3722b..1bf6d46200 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -147,6 +147,7 @@ (define-module (gnu packages wm)
>    #:use-module (gnu packages python-xyz)
>    #:use-module (gnu packages readline)
>    #:use-module (gnu packages serialization)
> +  #:use-module (gnu packages shells)
>    #:use-module (gnu packages sphinx)
>    #:use-module (gnu packages suckless)
>    #:use-module (gnu packages texinfo)
> @@ -1761,7 +1762,7 @@ (define-public swaybg
>  (define-public swaynotificationcenter
>    (package
>      (name "swaynotificationcenter")
> -    (version "0.7.3")
> +    (version "0.8.0")
>      (source (origin
>                (method git-fetch)
>                (uri (git-reference
> @@ -1769,7 +1770,7 @@ (define-public swaynotificationcenter
>                      (commit (string-append "v" version))))
>                (file-name (git-file-name name version))
>                (sha256
> -               (base32 "1xvr5m5sqznr3dd512i5pk0d56v7n0ywdcy6rnz85vbf2k7b6kj5"))))
> +               (base32 "1c3gd6mlr209jzzrh5jmws2lawnn3gr6smvzcw74kkpi3wvs7l0k"))))
>      (build-system meson-build-system)
>      (arguments (list #:configure-flags #~(list "-Dsystemd-service=false")))
>      (native-inputs
> @@ -1780,11 +1781,15 @@ (define-public swaynotificationcenter
>             scdoc
>             vala))
>      (inputs
> -     (list json-glib
> +     (list bash-completion
> +           fish
> +           json-glib
>             glib
>             gtk+
>             gtk-layer-shell
>             libhandy
> +           libgee
> +           pulseaudio
>             wayland-protocols))

Hi Brian,

Regarding these new inputs, what's you're reasoning for adding them?

fish stood out to me, it doesn't seem to be referenced by the
swaynotificationcenter output (doesn't show up in guix size), so maybe
it should be a native-input if it's some test dependency?

Thanks,

Chris
Brian Cully June 12, 2023, 7:11 p.m. UTC | #2
Christopher Baines <mail@cbaines.net> writes:

>>      (inputs
>> -     (list json-glib
>> +     (list bash-completion
>> +           fish
>> +           json-glib
>>             glib
>>             gtk+
>>             gtk-layer-shell
>>             libhandy
>> +           libgee
>> +           pulseaudio
>>             wayland-protocols))
>
> Regarding these new inputs, what's you're reasoning for adding 
> them?

In general: so that configure would find everything it was looking 
for. I believe the only new hard requirement is libgee and 
json-glib (I can test a build without them and see how far I get, 
but it'll have to wait until I have a bit more time).

The others — bash-completion and fish — are for command 
completion, I believe. Do those better belong in native-inputs 
just so the can be detected during configure-time?

-bjc
Brian Cully June 16, 2023, 11:12 p.m. UTC | #3
Brian Cully <bjc@spork.org> writes:

> Christopher Baines <mail@cbaines.net> writes:
>
>>>      (inputs
>>> -     (list json-glib
>>> +     (list bash-completion
>>> +           fish
>>> +           json-glib
>>>             glib
>>>             gtk+
>>>             gtk-layer-shell
>>>             libhandy
>>> +           libgee
>>> +           pulseaudio
>>>             wayland-protocols))
>>
>> Regarding these new inputs, what's you're reasoning for adding 
>> them?
>
> In general: so that configure would find everything it was 
> looking
> for. I believe the only new hard requirement is libgee and 
> json-glib
> (I can test a build without them and see how far I get, but 
> it'll have
> to wait until I have a bit more time).

I re-ran the build today, and the output from the configure phase 
does specify that ‘libgee’, ‘json-glib’, and ‘pulseaudio’ are 
runtime dependencies:

--8<---------------cut here---------------start------------->8---
Run-time dependency json-glib-1.0 found: YES 1.6.2
[…]
Run-time dependency gee-0.8 found: YES 0.20.5
Run-time dependency libpulse found: YES 16.1
Run-time dependency libpulse-mainloop-glib found: YES 16.1
--8<---------------cut here---------------end--------------->8---


> The others — bash-completion and fish — are for command 
> completion, I
> believe. Do those better belong in native-inputs just so the can 
> be
> detected during configure-time?

But maybe ‘Run-time dependency’ is a mis-labelling. Compiling 
without the ‘bash-completion’ or ‘fish’ inputs generates the 
complaints:

--8<---------------cut here---------------start------------->8---
Run-time dependency bash-completion found: NO (tried pkgconfig and 
cmake)
Run-time dependency fish found: NO (tried pkgconfig and cmake)
--8<---------------cut here---------------end--------------->8---

But it still installs the completion files:

--8<---------------cut here---------------start------------->8---
Installing 
/tmp/guix-build-swaynotificationcenter-0.8.0.drv-0/source/completions/zsh/_swaync 
to 
/gnu/store/5v2p9n53ivj7cmq7m442gy6yvzqn9vbz-swaynotificationcenter-0.8.0/share/zsh/site-functions
Installing 
/tmp/guix-build-swaynotificationcenter-0.8.0.drv-0/source/completions/zsh/_swaync-client 
to 
/gnu/store/5v2p9n53ivj7cmq7m442gy6yvzqn9vbz-swaynotificationcenter-0.8.0/share/zsh/site-functions
Installing 
/tmp/guix-build-swaynotificationcenter-0.8.0.drv-0/source/completions/bash/swaync 
to 
/gnu/store/5v2p9n53ivj7cmq7m442gy6yvzqn9vbz-swaynotificationcenter-0.8.0/share/bash-completion/completions
Installing 
/tmp/guix-build-swaynotificationcenter-0.8.0.drv-0/source/completions/bash/swaync-client 
to 
/gnu/store/5v2p9n53ivj7cmq7m442gy6yvzqn9vbz-swaynotificationcenter-0.8.0/share/bash-completion/completions
Installing 
/tmp/guix-build-swaynotificationcenter-0.8.0.drv-0/source/completions/fish/swaync.fish 
to 
/gnu/store/5v2p9n53ivj7cmq7m442gy6yvzqn9vbz-swaynotificationcenter-0.8.0/share/fish/vendor_completions.d
Installing 
/tmp/guix-build-swaynotificationcenter-0.8.0.drv-0/source/completions/fish/swaync-client.fish 
to 
/gnu/store/5v2p9n53ivj7cmq7m442gy6yvzqn9vbz-swaynotificationcenter-0.8.0/share/fish/vendor_completions.d
--8<---------------cut here---------------end--------------->8---

Note also that ‘zsh’ gets completions as well, even though it's 
not being checked for in the configuration phase.

Starting a shell with fish:

--8<---------------cut here---------------start------------->8---
/pre-inst-env guix shell -CP coreutils fish bash 
swaynotificationcenter -- fish
--8<---------------cut here---------------end--------------->8---

Yields completion candidates for ‘swaync’ and ‘swaync-client’, 
even though I've removed those inputs, so it seems they're not 
necessary.

I'll submit a v2 without the ‘fish’ and ‘bash’ inputs shortly.
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 4360f3722b..1bf6d46200 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -147,6 +147,7 @@  (define-module (gnu packages wm)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages serialization)
+  #:use-module (gnu packages shells)
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages suckless)
   #:use-module (gnu packages texinfo)
@@ -1761,7 +1762,7 @@  (define-public swaybg
 (define-public swaynotificationcenter
   (package
     (name "swaynotificationcenter")
-    (version "0.7.3")
+    (version "0.8.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1769,7 +1770,7 @@  (define-public swaynotificationcenter
                     (commit (string-append "v" version))))
               (file-name (git-file-name name version))
               (sha256
-               (base32 "1xvr5m5sqznr3dd512i5pk0d56v7n0ywdcy6rnz85vbf2k7b6kj5"))))
+               (base32 "1c3gd6mlr209jzzrh5jmws2lawnn3gr6smvzcw74kkpi3wvs7l0k"))))
     (build-system meson-build-system)
     (arguments (list #:configure-flags #~(list "-Dsystemd-service=false")))
     (native-inputs
@@ -1780,11 +1781,15 @@  (define-public swaynotificationcenter
            scdoc
            vala))
     (inputs
-     (list json-glib
+     (list bash-completion
+           fish
+           json-glib
            glib
            gtk+
            gtk-layer-shell
            libhandy
+           libgee
+           pulseaudio
            wayland-protocols))
     (synopsis "Notification daemon with a graphical interface")
     (description