diff mbox series

[bug#68891] gnu: emacs-org-board: Update to 1138-2.500fe02.

Message ID c733335e117a7e826d67f2d11130f34ab5e81ab4.1706863516.git.csantosb@inventati.org
State New
Headers show
Series [bug#68891] gnu: emacs-org-board: Update to 1138-2.500fe02. | expand

Commit Message

Cayetano Santos Feb. 2, 2024, 8:45 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-org-board): Update to 1138-2.500fe02.
---
 gnu/packages/emacs-xyz.scm | 12 +++++-------
 1 file changed, 5 insertions(+), 7 deletions(-)


base-commit: c692808a5e1413480162be1406186a63bd92651c

Comments

Christopher Baines Feb. 13, 2024, 11:21 a.m. UTC | #1
Cayetano Santos via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-org-board): Update to 1138-2.500fe02.
> ---
>  gnu/packages/emacs-xyz.scm | 12 +++++-------
>  1 file changed, 5 insertions(+), 7 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index c7e6852194..3e6d09c509 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -27782,8 +27782,8 @@ (define-public emacs-cpreproc-openvdb
>     (license license:gpl3+)))
>  
>  (define-public emacs-org-board
> -  (let ((commit "1393bd46d11a81328ed4fb8471831415a3efe224")
> -        (revision "1"))
> +  (let ((commit "500fe02bc114e5b535a2eb2ab73954d79428168f")
> +        (revision "2"))
>      (package
>        (name "emacs-org-board")
>        (version (git-version "1138" revision commit))
> @@ -27795,7 +27795,7 @@ (define-public emacs-org-board
>                  (file-name (git-file-name name version))
>                  (sha256
>                   (base32
> -                  "1kryrg988c3sbxyp1sdgc6xdv2iz6kiflpzn2rw4z3l4grzab53b"))))
> +                  "1mcghw9mmlyqsgxk97hd57495sfx8dp6ig7qgs5xn2b2k0ygv4vf"))))
>        (build-system emacs-build-system)
>        (arguments
>         (list
> @@ -27805,11 +27805,9 @@ (define-public emacs-org-board
>                (lambda* (#:key inputs #:allow-other-keys)
>                  (emacs-substitute-variables "org-board.el"
>                    ("org-board-wget-program"
> -                   (search-input-file inputs "/bin/wget"))))))))
> -      (inputs
> -       (list wget))
> +                   (search-input-file inputs "/bin/wget2"))))))))
>        (propagated-inputs
> -       (list emacs-org emacs-ztree))
> +       (list emacs-ztree wget2))

Thanks for the patch, these changes around wget/wget2 look confusing to
me though.

The reason for the emacs-substitute-variables bit is to allow wget to
just be an input rather than a propagated input, but you're making wget2
a propagated input here. This change and the motivation behind it is
also missing from the commit message.

Thanks,

Chris
Deslauriers, Douglas via Guix-patches" via Feb. 13, 2024, 1:18 p.m. UTC | #2
>mar. 13 févr. 2024 at 11:21, Christopher Baines <mail@cbaines.net> wrote:

> Thanks for the patch, these changes around wget/wget2 look confusing to
> me though.
>
> The reason for the emacs-substitute-variables bit is to allow wget to
> just be an input rather than a propagated input, but you're making wget2
> a propagated input here. This change and the motivation behind it is
> also missing from the commit message.

When one installs emacs-org-board, wget2-2.1.0 gets installed along with
it as for emacs-substitute-variables, as you say, and the variable
org-board-wget-program is bound to this hardcoded value.

Once one decides to upgrade wget2 to something different (say, in a
different profile), this logic breaks. User needs to manually bind
org-board-wget-program to whatever wget2 is after upgrading. At this
point, wget2 becomes a native-input requirement.

Please, correct me if I’m wrong.

Cayetano
Nicolas Goaziou Feb. 22, 2024, 10:52 a.m. UTC | #3
Hello,

Cayetano Santos via Guix-patches via <guix-patches@gnu.org> writes:

> When one installs emacs-org-board, wget2-2.1.0 gets installed along with
> it as for emacs-substitute-variables, as you say, and the variable
> org-board-wget-program is bound to this hardcoded value.

Correct.

> Once one decides to upgrade wget2 to something different (say, in a
> different profile), this logic breaks. User needs to manually bind
> org-board-wget-program to whatever wget2 is after upgrading. At this
> point, wget2 becomes a native-input requirement.

This is not correct. No action is required from the user.
`org-board-wget-program' still points to the wget program defined as an
input to emacs-org-board, and will still be used at run time.

Of course, the user still can point `org-board-wget-program' to their
new and shiny wget binary, but this is not required.

I also suggest to keep wget (or wget2) as an input and use
`emacs-substitute-variables'.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c7e6852194..3e6d09c509 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27782,8 +27782,8 @@  (define-public emacs-cpreproc-openvdb
    (license license:gpl3+)))
 
 (define-public emacs-org-board
-  (let ((commit "1393bd46d11a81328ed4fb8471831415a3efe224")
-        (revision "1"))
+  (let ((commit "500fe02bc114e5b535a2eb2ab73954d79428168f")
+        (revision "2"))
     (package
       (name "emacs-org-board")
       (version (git-version "1138" revision commit))
@@ -27795,7 +27795,7 @@  (define-public emacs-org-board
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "1kryrg988c3sbxyp1sdgc6xdv2iz6kiflpzn2rw4z3l4grzab53b"))))
+                  "1mcghw9mmlyqsgxk97hd57495sfx8dp6ig7qgs5xn2b2k0ygv4vf"))))
       (build-system emacs-build-system)
       (arguments
        (list
@@ -27805,11 +27805,9 @@  (define-public emacs-org-board
               (lambda* (#:key inputs #:allow-other-keys)
                 (emacs-substitute-variables "org-board.el"
                   ("org-board-wget-program"
-                   (search-input-file inputs "/bin/wget"))))))))
-      (inputs
-       (list wget))
+                   (search-input-file inputs "/bin/wget2"))))))))
       (propagated-inputs
-       (list emacs-org emacs-ztree))
+       (list emacs-ztree wget2))
       (home-page "https://github.com/charlesroelli/org-board")
       (synopsis "Bookmarking and web archival system for Org mode")
       (description