diff mbox series

[bug#65845] gnu: Add netperf.

Message ID c7128dd3f812d0b880a3bf6901ac77d5a12a79da.1694296141.git.attila@lendvai.name
State New
Headers show
Series [bug#65845] gnu: Add netperf. | expand

Commit Message

Attila Lendvai Sept. 9, 2023, 9:49 p.m. UTC
* gnu/packages/networking.scm (netperf): New variable.
---
originally i added this to as a dependency for flint, but i got stuck with flint
packaging (it wants to invoke binaries from the PATH).

the itch is gone that originally initiated my packaging, so flint probably won't
be finished by me, but netperf is useful by itself.

 gnu/packages/networking.scm | 38 +++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)


base-commit: e365c26a34fa485f9af46538fcea128db681c33d
prerequisite-patch-id: ecd98c3607846b732bde724a08cae56ffec4a6c3
prerequisite-patch-id: 6793c8ad24215c5f14ce71a4741fff5f6ccd7eeb
prerequisite-patch-id: 52e0d371350dbeb839990acd0bbe70bc5b5b995b
prerequisite-patch-id: 504c90457c9d79e43b99ee020ba694d8caeb90d8
prerequisite-patch-id: d64e04ff364130aa81dfba39ac9d7acf9da4a384
prerequisite-patch-id: 4eaf6383c3eb26aadbd0caf24a0bc100ddc87ed6
prerequisite-patch-id: 06efe04a27135ca3d6cf817c057b28558adc36c7
prerequisite-patch-id: 8c31ac25a4efbd194ca3b7a65a097deaa26d015a
prerequisite-patch-id: 1166ab46a52df0924076b071edc3c9c1c3357bf8
prerequisite-patch-id: 9083830fd89c8d814b1911970522b7746b86643a
prerequisite-patch-id: 02cfc74134e55855d6f113b3bc877cd8a9fabf58
prerequisite-patch-id: 57e3ce092cb3ce3f1baab5811cc775c94c8d176c
prerequisite-patch-id: a7efb6bed2b8436ef747c10a90a9937bfc64995c
prerequisite-patch-id: 7f15cb5ac54a485ba366c258aafc507a50bd05e6
prerequisite-patch-id: a31227853bac471122393c16e575d2bcdedb979f

Comments

Ludovic Courtès Sept. 18, 2023, 9:37 p.m. UTC | #1
Hi Attila,

Attila Lendvai <attila.lendvai@gmail.com> skribis:

> * gnu/packages/networking.scm (netperf): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f4ecd85009..163cc0a3ff 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -286,6 +286,44 @@  (define-public lcrq
 the RFC.")
     (license (list license:gpl2 license:gpl3))))
 
+(define-public netperf
+  (let ((version "2.7.0")
+        (revision "1")
+        (commit "3bc455b23f901dae377ca0a558e1e32aa56b31c4"))
+    (package
+      (name "netperf")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/HewlettPackard/netperf")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1msbhbvf39r1a0c9b9myla5i6235fvnp7r6021fl8b5svxjbb0dk"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:configure-flags
+         ;; Without -fcommon the build fails on newer gcc.
+         ;; See: https://gcc.gnu.org/gcc-10/porting_to.html
+         (list "CFLAGS=-fcommon"
+               ;; --enable-demo is needed for flent (not yet packaged).
+               "--enable-demo")))
+      (native-inputs
+       (list autoconf
+             automake))
+      (home-page "https://hewlettpackard.github.io/netperf/")
+      (synopsis "Benchmarking tool to measure network performance")
+      (description
+       "Netperf is a benchmark that can be used to measure the performance of
+many different types of networking.  It provides tests for both unidirectional
+throughput, and end-to-end latency.  The environments currently measureable
+by netperf include: TCP and UDP via BSD Sockets for both IPv4 and IPv6, DLPI,
+Unix Domain Sockets, SCTP for both IPv4 and IPv6.")
+      (license license:expat))))
+
 (define-public lcsync
   (package
     (name "lcsync")