[bug#71968,v8,2/3] gnu: fastfetch: Update to 2.34.1.
Commit Message
* gnu/packages/admin.scm (fastfetch): Update to 2.34.1.
[origin]: Add snippet to remove third party code.
[#:configure-flags]: Disable bundled yyjson, disable flashfetch, enable tests and skip installing license.
[native-inputs]: Add python-minimal.
[inputs]: Add yyjson.
Change-Id: I52d5cf244726bf4362f658f818094a483e3b3d01
---
gnu/packages/admin.scm | 17 +++++++++++++----
1 file changed, 13 insertions(+), 4 deletions(-)
@@ -4450,7 +4450,7 @@ (define-public pfetch
(define-public fastfetch
(package
(name "fastfetch")
- (version "2.34.0")
+ (version "2.34.1")
(source
(origin
(method git-fetch)
@@ -4459,17 +4459,26 @@ (define-public fastfetch
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "17033prhikj3aajfcfzi0mjc4487hyq5r2av38rw59yb95hl6fv5"))))
+ (base32 "1fb8ix2wxvqb414gvc6174dwigpixswbysq7yp9c3rw3c55r294h"))
+ (modules '((guix build utils)))
+ (snippet '(begin
+ (delete-file-recursively "src/3rdparty")))))
(build-system cmake-build-system)
+ (arguments
+ (list
+ #:configure-flags #~(list "-DENABLE_SYSTEM_YYJSON=ON"
+ "-DBUILD_FLASHFETCH=OFF"
+ "-DBUILD_TESTS=ON"
+ "-DINSTALL_LICENSE=OFF")))
(inputs (list dbus
glib
imagemagick
libxcb
mesa
wayland
+ yyjson
zlib)) ;for imagemagick and an #ifdef
- (native-inputs (list pkg-config))
- (arguments (list #:tests? #f)) ; no test target
+ (native-inputs (list pkg-config python-minimal))
(home-page "https://github.com/fastfetch-cli/fastfetch")
(synopsis "Display system information in a stylized manner")
(description