[bug#76770] gnu: lua: compile with readline support

Message ID c6f7f6d3-6c9b-4862-ae9e-0357218082ab@mail.ru
State New
Headers
Series [bug#76770] gnu: lua: compile with readline support |

Commit Message

kimapr March 5, 2025, 5:37 p.m. UTC
  * gnu/packages/lua.scm (lua)[arguments]: change target to
  "linux-readline".
---
 gnu/packages/lua.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

          (delete 'configure)
  

Comments

Vagrant Cascadian March 10, 2025, 10:46 p.m. UTC | #1
On 2025-03-05, kimapr wrote:
> * gnu/packages/lua.scm (lua)[arguments]: change target to
>   "linux-readline".
> ---
>  gnu/packages/lua.scm | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
> index 4c65bcbf12..b3d4cbf5d2 100644
> --- a/gnu/packages/lua.scm
> +++ b/gnu/packages/lua.scm
> @@ -109,7 +109,7 @@ (define-public lua
>               (string-append "CC=" ,(cc-for-target))
>               (string-append "SYSLIBS=-L" (assoc-ref %build-inputs
> "readline")
>                              "/lib")
> -             "linux")
> +             "linux-readline")
>         #:phases
>         (modify-phases %standard-phases
>           (delete 'configure)
> -- 
> 2.47.1

Patch was slightly malformed for some reason, but being a one-liner, was
easy to apply manually!

At first glance, it increases the results from guix size only slightly
from 77.0MB to 84.4MB, and has a smallish number of dependents...

But lua@5.1 lua@5.2 and lua@5.3 inherit from lua, so the impact is much
larger than a quick glance suggests (especially lua@5.3):

    $ guix refresh --list-dependent lua@5.1 lua@5.2 lua@5.3 lua@5.4
    Building the following 359 packages would ensure 604 dependent
    packages are rebuilt: grafx2@2.4 hedgewars@1.0.2 btanks@0.9.8083
    crawl-tiles@0.32.1 fillets-ng@1.0.1 ...

I did successfully build lua@5.4 and it's four dependents.

https://guix.gnu.org/manual/devel/en/guix.html#Managing-Patches-and-Branches

  Changes which affect more than 300 dependent packages (see Invoking guix
  refresh) should first be pushed to a topic branch other than master

Would it make sense to exclude the older versions from the change? Then
it could go to the git master banch, in my opinion.


live well,
  vagrant
  
Vagrant Cascadian March 10, 2025, 11:34 p.m. UTC | #2
On 2025-03-10, Vagrant Cascadian wrote:
> On 2025-03-05, kimapr wrote:
> At first glance, it increases the results from guix size only slightly
> from 77.0MB to 84.4MB, and has a smallish number of dependents...
>
> But lua@5.1 lua@5.2 and lua@5.3 inherit from lua, so the impact is much
> larger than a quick glance suggests (especially lua@5.3):

Oops, I had this slightly wrong... lua-5.1, lua-5.2 and lua-5.4 inherit
from lua (which is effectively lua@5.3).

> Would it make sense to exclude the older versions from the change? Then
> it could go to the git master banch, in my opinion.

In fact versions 5.1, 5.2 and 5.3 do not support this option passed to
make at all, and fail to build with the patch applied!

I just checked that lua@5.3, lua@5.2 and lua@5.1 all do support
readline, so it is only lua@5.4 that does not currently have readline
support.

So the patch needs to be re-worked ot only apply to lua-5.4. But then
should be able to be pushed directly as it does not have many
dependents.


live well,
  vagrant
  
kimapr March 11, 2025, 7:24 a.m. UTC | #3
On 2025/03/11 04:34, Vagrant Cascadian wrote:
> So the patch needs to be re-worked ot only apply to lua-5.4. But then
> should be able to be pushed directly as it does not have many
> dependents.

I have done this, however my email client is very evil and keeps messing up my formatting no matter what I try so sending the patch without malforming it proves difficult. (word-wrapping, randomly deleting spaces, i thought i disabled the former but it's still doing it and the latter simply makes no sense in any context)

This is a problem to solve later (by using a different client), for now I will just send the patch in base64 instead to protect it against my evil email client:

RnJvbSA1MjcxOTYwNzZjZWM2MmIxNTk3Zjk2NTA1MmRjMmJhMWNkYTdlYzQyIE1vbiBTZXAgMTcg
MDA6MDA6MDAgMjAwMQpGcm9tOiBLaW1hcHIgPGtpbWFwckBtYWlsLnJ1PgpEYXRlOiBUdWUsIDEx
IE1hciAyMDI1IDExOjQzOjM0ICswNTAwClN1YmplY3Q6IFtQQVRDSF0gZ251OiBsdWEtNS40OiBj
b21waWxlIHdpdGggcmVhZGxpbmUgc3VwcG9ydAoKKiBnbnUvcGFja2FnZXMvbHVhLnNjbSAobHVh
LTUuNClbYXJndW1lbnRzXTogY2hhbmdlIHRhcmdldCB0bwogICJsaW51eC1yZWFkbGluZSIuCi0t
LQogZ251L3BhY2thZ2VzL2x1YS5zY20gfCA2ICsrKysrKwogMSBmaWxlIGNoYW5nZWQsIDYgaW5z
ZXJ0aW9ucygrKQoKZGlmZiAtLWdpdCBhL2dudS9wYWNrYWdlcy9sdWEuc2NtIGIvZ251L3BhY2th
Z2VzL2x1YS5zY20KaW5kZXggNGM2NWJjYmYxMi4uMGU0NWFmMTJhMiAxMDA2NDQKLS0tIGEvZ251
L3BhY2thZ2VzL2x1YS5zY20KKysrIGIvZ251L3BhY2thZ2VzL2x1YS5zY20KQEAgLTEzNCw2ICsx
MzQsMTIgQEAgKGRlZmluZS1wdWJsaWMgbHVhCiAoZGVmaW5lLXB1YmxpYyBsdWEtNS40CiAgIChw
YWNrYWdlIChpbmhlcml0IGx1YSkKICAgICAgICAgICAgKHZlcnNpb24gIjUuNC42IikKKyAgICAg
ICAgICAgKGFyZ3VtZW50cworICAgICAgICAgICAgKHN1YnN0aXR1dGUta2V5d29yZC1hcmd1bWVu
dHMgKHBhY2thZ2UtYXJndW1lbnRzIGx1YSkKKyAgICAgICAgICAgICAgKCgjOm1ha2UtZmxhZ3Mg
ZmxhZ3MpCisgICAgICAgICAgICAgICAoYXBwZW5kIChsaXN0LWhlYWQgZmxhZ3MKKyAgICAgICAg
ICAgICAgICAgICAgICAgICAgICAgICAgICAoLSAobGVuZ3RoIGZsYWdzKSAxKSkKKyAgICAgICAg
ICAgICAgICAgICAgICAgJygibGludXgtcmVhZGxpbmUiKSkpKSkKICAgICAgICAgICAgKHNvdXJj
ZSAob3JpZ2luCiAgICAgICAgICAgICAgICAgICAgICAobWV0aG9kIHVybC1mZXRjaCkKICAgICAg
ICAgICAgICAgICAgICAgICh1cmkgKHN0cmluZy1hcHBlbmQgImh0dHBzOi8vd3d3Lmx1YS5vcmcv
ZnRwL2x1YS0iCi0tIAoyLjQ4LjEKCg==
  

Patch

diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 4c65bcbf12..b3d4cbf5d2 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -109,7 +109,7 @@  (define-public lua
              (string-append "CC=" ,(cc-for-target))
              (string-append "SYSLIBS=-L" (assoc-ref %build-inputs
"readline")
                             "/lib")
-             "linux")
+             "linux-readline")
        #:phases
        (modify-phases %standard-phases