diff mbox series

[bug#38827] gnu: Add gitlab-runner.

Message ID c6f32241-012b-4eca-a183-cf0d38df435e@www.fastmail.com
State Work in progress
Headers show
Series [bug#38827] gnu: Add gitlab-runner. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Reza Alizadeh Majd Dec. 31, 2019, 3:48 p.m. UTC
Hi,
 
> [1]: 
> https://guix.gnu.org/manual/en/html_node/Formatting-Code.html#Formatting-Code
> [2]: 
> https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html#Synopses-and-Descriptions

I update the package definition following the above guidelines.
could you please check if this updated patch is acceptable?

Comments

Mathieu Othacehe Dec. 31, 2019, 4:09 p.m. UTC | #1
> I update the package definition following the above guidelines.
> could you please check if this updated patch is acceptable?

I fixed the indentation, added one space between the two description
sentences and pushed.

Thanks for your contribution,

Mathieu
Mathieu Othacehe Dec. 31, 2019, 4:09 p.m. UTC | #2
and closing!

Mathieu
Ludovic Courtès Dec. 31, 2019, 11:54 p.m. UTC | #3
Hello!

Mathieu Othacehe <m.othacehe@gmail.com> skribis:

>> I update the package definition following the above guidelines.
>> could you please check if this updated patch is acceptable?
>
> I fixed the indentation, added one space between the two description
> sentences and pushed.

The ‘vendor’ directory contains a large number of bundled dependencies,
including various bits of Docker and Kubernetes.  I’m not comfortable
keeping this package as is.

Reza, could you look into unbundling these, or at least a significant
part of these?

There’s a Go importer at
<https://lists.gnu.org/archive/html/guix-devel/2018-04/msg00301.html>,
but it’s for ‘Gopkg.toml’ files, which seem to be out of fashion, so I’m
not sure it’d be useful.

In the meantime, I’d be in favor of reverting the patch.  WDYT?

Thanks,
Ludo’.
Efraim Flashner Jan. 1, 2020, 12:20 p.m. UTC | #4
On Wed, Jan 01, 2020 at 12:54:37AM +0100, Ludovic Courtès wrote:
> Hello!
> 
> Mathieu Othacehe <m.othacehe@gmail.com> skribis:
> 
> >> I update the package definition following the above guidelines.
> >> could you please check if this updated patch is acceptable?
> >
> > I fixed the indentation, added one space between the two description
> > sentences and pushed.
> 
> The ‘vendor’ directory contains a large number of bundled dependencies,
> including various bits of Docker and Kubernetes.  I’m not comfortable
> keeping this package as is.
> 
> Reza, could you look into unbundling these, or at least a significant
> part of these?
> 
> There’s a Go importer at
> <https://lists.gnu.org/archive/html/guix-devel/2018-04/msg00301.html>,
> but it’s for ‘Gopkg.toml’ files, which seem to be out of fashion, so I’m
> not sure it’d be useful.
> 
> In the meantime, I’d be in favor of reverting the patch.  WDYT?
> 

Unfortunately I'm in agreement. I personally would keep in in a channel
until it's been de-vendored.
Mathieu Othacehe Jan. 1, 2020, 6:58 p.m. UTC | #5
Hey,

> The ‘vendor’ directory contains a large number of bundled dependencies,
> including various bits of Docker and Kubernetes.  I’m not comfortable
> keeping this package as is.

Oops, that's indeed quite problematic. Sorry for not noticing, reverted
until we can find a better way.

Mathieu
diff mbox series

Patch

From 3fd96ceea56d6c16036398a96dd9051ce51afe63 Mon Sep 17 00:00:00 2001
From: Reza Alizadeh Majd <r.majd@pantherx.org>
Date: Tue, 31 Dec 2019 12:37:42 +0330
Subject: [PATCH] gnu: Add gitlab-runner.

* gnu/packages/ci.scm (gitlab-runner): New variable.
---
 gnu/packages/ci.scm | 25 ++++++++++++++++++++++++-
 1 file changed, 24 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index b49ac0f7c1..0515a62481 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -5,6 +5,7 @@ 
 ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2020 Reza Alizadeh Majd <r.majd@pantherx.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -25,6 +26,7 @@ 
   #:use-module ((guix licenses) #:prefix l:)
   #:use-module (gnu packages)
   #:use-module (guix packages)
+  #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
@@ -44,7 +46,8 @@ 
   #:use-module (gnu packages version-control)
   #:use-module (gnu packages web)
   #:use-module (gnu packages xml)
-  #:use-module (guix build-system gnu))
+  #:use-module (guix build-system gnu)
+  #:use-module (guix build-system go))
 
 (define-public cuirass
   (let ((commit "e20ff86d97f7dd92dad140b5919e3cbdf2fb1ce6")
@@ -152,3 +155,23 @@ 
 intended as a replacement for Hydra.")
       (home-page "https://www.gnu.org/software/guix/")
       (license l:gpl3+))))
+
+(define-public gitlab-runner
+  (package
+    (name "gitlab-runner")
+    (version "12.6.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v"
+               version "/gitlab-runner-v" version ".tar.gz"))
+        (sha256
+          (base32 "1gb3mflz57niyyn4kj5l4m1g2sa2w4cn8gig5dfr04ns9w9kj8jr"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "gitlab.com/gitlab-org/gitlab-runner"))
+    (home-page "https://docs.gitlab.com/runner/")
+    (synopsis "GitLab Runner")
+    (description "Gitlab Runner is used to run Gitlab's CI/CD jobs and send
+back the results to Gitlab instance. It is used in conjunction with Gitlab CI.")
+    (license l:expat)))
-- 
2.24.1