diff mbox series

[bug#67999,v2] gnu: Add kalamine.

Message ID c6bdf5b36cde3ca4f29ed2f5fd2ad5eaf0cd7116.1709387988.git.sharlatanus@gmail.com
State New
Headers show
Series [bug#67999,v2] gnu: Add kalamine. | expand

Commit Message

Sharlatan Hellseher March 2, 2024, 2:08 p.m. UTC
From: Adriel Dumas--Jondeau <leirda@disroot.org>

* gnu/packages/python-xyz.scm (kalamine): New variable.

Change-Id: If13f258440bb35973b3d79a87fea68e4708845bf
Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
---
 gnu/packages/python-xyz.scm | 41 +++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)


base-commit: 4a0549be52f3f46fbce61342d8de30f7b83130c5

Comments

Adriel Dumas--Jondeau March 3, 2024, 2:34 p.m. UTC | #1
Hi,

Thank for your work and your input, I'll try to improve my futures
patches with these in mind :)
Nicolas Goaziou March 13, 2024, 8:59 a.m. UTC | #2
Hello,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

> From: Adriel Dumas--Jondeau <leirda@disroot.org>
>
> * gnu/packages/python-xyz.scm (kalamine): New variable.

Thanks to both of you. I updated the package to 0.36, removed some
unnecessary capitalization in the synopsis, and applied it.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fc6e997b6c..7410f40465 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -147,6 +147,7 @@ 
 ;;; Copyright © 2023 Attila Lendvai <attila@lendvai.name>
 ;;; Copyright © 2023, 2024 Troy Figiel <troy@troyfigiel.com>
 ;;; Copyright © 2024 Timothee Mathieu <timothee.mathieu@inria.fr>
+;;; Copyright © 2024 Adriel Dumas--Jondeau <leirda@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6375,6 +6376,46 @@  (define-public autokey
 flexibility and power of the Python language.")
     (license license:gpl3+)))
 
+(define-public kalamine
+  (package
+    (name "kalamine")
+    (version "0.33")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "kalamine" version))
+       (sha256
+        (base32 "11hci02lvjc8657lylfcdw24bff0g1q0qxi8wcrjgqcqka9vm63c"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'make-test-layouts
+            (lambda _
+              (apply invoke
+                     (cons* "python" "-m" "kalamine.cli" "build"
+                            (find-files "layouts" "\\.toml")))
+              (invoke "python" "-m" "kalamine.cli" "new" "test.toml"))))))
+    (propagated-inputs
+     (list python-click
+           python-livereload
+           python-lxml
+           python-progress
+           python-pyyaml
+           python-tomli))
+    ;; TODO: Add python-pytest-ruff to native-inputs once it has been
+    ;; packaged.
+    (native-inputs
+     (list python-hatchling python-mypy python-pytest))
+    (home-page "https://github.com/OneDeadKey/kalamine")
+    (synopsis "Keyboard Layout Maker")
+    (description
+     "Kalamine provides a CLI to create advanced keyboard layout from a
+textual portable description.  It also supports layout emulation via web
+browser.")
+    (license license:expat)))
+
 (define-public python-dm-tree
   (package
     (name "python-dm-tree")