[bug#66821,v2,3/3] gnu: Add pantheon-iconbrowser.
Commit Message
* gnu/packages/pantheon.scm (pantheon-iconbrowser): New variable.
Change-Id: I4c1b0aa8a5593e384214e4b1fbad4fef8eaedf4d
---
gnu/packages/pantheon.scm | 40 +++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)
@@ -136,6 +136,46 @@ (define-public pantheon-calculator
desktop.")
(license license:gpl3)))
+(define-public pantheon-iconbrowser
+ (package
+ (name "pantheon-iconbrowser")
+ (version "2.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elementary/iconbrowser")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0b1afyizq3c94qkf4cqy5jnb4v3nib5vc88k34r08c604p1z2h8p"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases (modify-phases %standard-phases
+ (add-after 'install 'install-symlinks
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out
+ "/bin/io.elementary.iconbrowser"))
+ (link (string-append out
+ "/bin/pantheon-iconbrowser")))
+ (symlink bin link)))))))
+ (native-inputs (list gettext-minimal ;for msgfmt
+ `(,glib "bin")
+ `(,gtk "bin")
+ pkg-config
+ vala))
+ (inputs (list granite gtk gtksourceview))
+ (synopsis "Browse and search system icons")
+ (description
+ "Icon Browser is an application for browsing system icons by
+category or searching them by name. It displays icons at different sizes, as
+well as code snippets (to use the icons in your own apps). It is designed for
+the Pantheon desktop environment (originally from elementary OS).")
+ (home-page "https://elementary.io/open-source")
+ (license license:gpl3+)))
+
(define-public pantheon-photos
(package
(name "pantheon-photos")