diff mbox series

[bug#66500,core-updates,2/3] gnu: docbook-dsssl: Refactor install-plan.

Message ID c699471a8b9d9597dc3dbdbd668710c812d2b22e.1697124046.git.mirai@makinata.eu
State New
Headers show
Series Custom output labels for copy-build-system. | expand

Commit Message

Bruno Victal Oct. 12, 2023, 3:30 p.m. UTC
Replace custom phase with copy-build-system newly added #:output parameter.
Additionally remove extra slashes from license URIs and obsolete inputs.

* gnu/packages/docbook.scm (docbook-dsssl)[source]: Remove empty directories
from source using a snippet.
[arguments]<#:phases>: Relocate 'install-doc logic into …
<#:install-plan>: … here. Remove obsolete exclusion rules.
[native-inputs]: Remove bzip2 and tar since these are already available by
default.
[license]: Remove extraneous slash.
(docbook-dsssl-doc)[license]: Remove extraneous slash.
---
 gnu/packages/docbook.scm | 26 ++++++++++----------------
 1 file changed, 10 insertions(+), 16 deletions(-)

Comments

Liliana Marie Prikler Oct. 19, 2023, 9:47 a.m. UTC | #1
Am Donnerstag, dem 12.10.2023 um 16:30 +0100 schrieb Bruno Victal:
> Replace custom phase with copy-build-system newly added #:output
> parameter.
> Additionally remove extra slashes from license URIs and obsolete
> inputs.
> 
> * gnu/packages/docbook.scm (docbook-dsssl)[source]: Remove empty
> directories from source using a snippet.
> [arguments]<#:phases>: Relocate 'install-doc logic into …
> <#:install-plan>: … here. Remove obsolete exclusion rules.
> [native-inputs]: Remove bzip2 and tar since these are already
> available by default.
> [license]: Remove extraneous slash.
> (docbook-dsssl-doc)[license]: Remove extraneous slash.
> ---
Are these extraneous slash removals really improving anything?  I
personally type file URIs with three slashes, but that's outside the
Guix context.

Cheers
Bruno Victal Oct. 19, 2023, 3:25 p.m. UTC | #2
On 2023-10-19 10:47, Liliana Marie Prikler wrote:
> Are these extraneous slash removals really improving anything?  I
> personally type file URIs with three slashes, but that's outside the
> Guix context.

It's mostly semantical improvements as I've explained in the
(unrelated) 1d07acb5f440cb3205b2336a213163ca4584d4f6 commit message [1].

Save for applications with broken or outdated URI handling (which would
be a bug), the single slash URIs work just the same as before.


[1]: <https://git.savannah.gnu.org/cgit/guix.git/commit/?h=core-updates&id=1d07acb5f440cb3205b2336a213163ca4584d4f6>
diff mbox series

Patch

diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index f7dff53808..07cb06059a 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -513,31 +513,25 @@  (define-public docbook-dsssl
                                   name "-" version ".tar.bz2"))
               (sha256
                (base32
-                "1g72y2yyc2k89kzs0lvrb9n7hjayw1hdskfpplpz97pf1c99wcig"))))
+                "1g72y2yyc2k89kzs0lvrb9n7hjayw1hdskfpplpz97pf1c99wcig"))
+              (snippet
+               #~(begin
+                   ;; Remove empty directories.
+                   (rmdir "doc")
+                   (rmdir "docsrc")))))
     (build-system copy-build-system)
     (outputs '("out" "doc"))
     (arguments
      (list
       #:install-plan
-      #~`(("./" "sgml/dtd/docbook/"
-           #:exclude ("doc" "docsrc")))
-      #:phases
-      #~(modify-phases %standard-phases
-          ;; The doc output contains 1.4 MiB of HTML documentation.
-          (add-after 'install 'install-doc
-            (lambda* (#:key inputs #:allow-other-keys)
-              (mkdir-p (string-append #$output:doc "/share/doc"))
-              (symlink (assoc-ref inputs "docbook-dsssl-doc")
-                       (format #f "~a/share/doc/~a-~a"
-                               #$output:doc #$name #$version)))))))
+      #~`(("./" "sgml/dtd/docbook/")
+          (#$(this-package-input "docbook-dsssl-doc") "./" #:output "doc"))))
     (inputs
      (list docbook-dsssl-doc))
-    (native-inputs
-     (list bzip2 tar))
     (home-page "https://docbook.org/")
     (synopsis "DSSSL style sheets for DocBook")
     (description "This package provides DSSSL style sheets for DocBook.")
-    (license (license:non-copyleft "file://README"))))
+    (license (license:non-copyleft "file:/README"))))
 
 ;;; Private variable, used as the 'doc' output of the docbook-dsssl package.
 (define docbook-dsssl-doc
@@ -560,7 +554,7 @@  (define docbook-dsssl-doc
     (home-page "https://docbook.org/")
     (synopsis "DocBook DSSSL style sheets documentation")
     (description "Documentation for the DocBook DSSSL style sheets.")
-    (license (license:non-copyleft "file://doc/LEGALNOTICE.htm"))))
+    (license (license:non-copyleft "file:/doc/LEGALNOTICE.htm"))))
 
 (define-public docbook-sgml-4.2
   (package