diff mbox series

[bug#57233] gnu: osm2pgsql: Update to 1.7.0.

Message ID c68ea7fc635b72d009a84b61d0f25b72849543ac.1660606710.git.sikmir@disroot.org
State Accepted
Headers show
Series [bug#57233] gnu: osm2pgsql: Update to 1.7.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nikolay Korotkiy Aug. 15, 2022, 11:38 p.m. UTC
* gnu/packages/geo.scm (osm2pgsql): Update to 1.7.0.
---
 gnu/packages/geo.scm | 23 +++++++++++------------
 1 file changed, 11 insertions(+), 12 deletions(-)

Comments

Guillaume Le Vaillant Aug. 17, 2022, 8:19 a.m. UTC | #1
Patch pushed as 0b69ed70eca72aef6364be650d9e2f7e8c97ac0c with
a completed commit message.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index fe2174b106..274beb0524 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -100,6 +100,7 @@  (define-module (gnu packages geo)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages photo)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages pretty-print)
   #:use-module (gnu packages protobuf)
   #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages python)
@@ -1322,7 +1323,7 @@  (define-public osmium-tool
 (define-public osm2pgsql
   (package
     (name "osm2pgsql")
-    (version "1.5.1")
+    (version "1.7.0")
     (source
      (origin
        (method git-fetch)
@@ -1331,32 +1332,30 @@  (define-public osm2pgsql
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0i18mskcs087dn3f3h9n7j0wafn8502m0h13mrjwin38xsz0crfj"))
+        (base32 "15fxr4xq7siy237763l7nswx7v0swr3qzs2h3zkjzgvajw4p6qii"))
        (modules '((guix build utils)))
        (snippet
-        '(begin
-           (delete-file-recursively "contrib/protozero")
-           (delete-file-recursively "contrib/libosmium")
-           #t))))
+        ;; Remove bundled libraries.
+        '(delete-file-recursively "contrib"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f; tests fail because we need to setup a database
        #:configure-flags
-       (list (string-append "-DOSMIUM_INCLUDE_DIR="
-                            (assoc-ref %build-inputs "libosmium")
-                            "/include")
-             (string-append "-DPROTOZERO_INCLUDE_DIR="
-                            (assoc-ref %build-inputs "protozero")
-                            "/include"))))
+       (list "-DEXTERNAL_LIBOSMIUM=ON"
+             "-DEXTERNAL_PROTOZERO=ON"
+             "-DEXTERNAL_FMT=ON"
+             "-DEXTERNAL_RAPIDJSON=ON")))
     (inputs
      (list boost
            bzip2
            expat
+           fmt
            libosmium
            lua
            postgresql
            proj
            protozero
+           rapidjson
            zlib))
     (native-inputs
      (list python python-psycopg2))