diff mbox series

[bug#66521] gnu: Add taskflow.

Message ID c68ab7f6537391181d66f3770a9a900521b70d77.1697206597.git.paul@apatience.com
State New
Headers show
Series [bug#66521] gnu: Add taskflow. | expand

Commit Message

Paul A. Patience Oct. 13, 2023, 2:17 p.m. UTC
* gnu/packages/cpp.scm (taskflow): New variable.
---
 gnu/packages/cpp.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: f4e8baf3806e79d7111d2943859865ae4ee0b59d

Comments

Ludovic Courtès Oct. 14, 2023, 8:35 p.m. UTC | #1
"Paul A. Patience" <paul@apatience.com> skribis:

> * gnu/packages/cpp.scm (taskflow): New variable.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 7d9eb2a264..f3f6d8df64 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -38,6 +38,7 @@ 
 ;;; Copyright © 2023 Liliana Marie Prikler <liliana.prikler@gmail.com>
 ;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
+;;; Copyright © 2023 Paul A. Patience <paul@apatience.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1039,6 +1040,28 @@  (define-public sobjectizer
 development of concurrent and multithreaded applications in C++.")
     (license license:bsd-3)))
 
+(define-public taskflow
+  (package
+    (name "taskflow")
+    (version "3.6.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/taskflow/taskflow")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1cv74l181137lchc1rxygcg401cnq216ymq5qz2njsw99j342br3"))))
+    (build-system cmake-build-system)
+    (home-page "https://taskflow.github.io/")
+    (synopsis
+     "General-purpose parallel and heterogeneous task programming system")
+    (description
+     "Taskflow is a C++ library for writing parallel and heterogeneous task
+programs.")
+    (license license:expat)))
+
 (define-public tweeny
   (package
     (name "tweeny")