diff mbox series

[bug#66913] gnu: Add r-miamiplot.

Message ID c6504183be8232325fb5af56c99bf34331aead24.1699016729.git.Navid.Afkhami@mdc-berlin.de
State New
Headers show
Series [bug#66913] gnu: Add r-miamiplot. | expand

Commit Message

nafkhamdc Nov. 3, 2023, 1:05 p.m. UTC
* gnu/packages/bioinformatics.scm (r-miamiplot): New variable.

Change-Id: I41a3a951c6f1835800301e4c168eeeb0dd299f06
---
 gnu/packages/bioinformatics.scm | 34 +++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)


base-commit: 28ebbe2be8829a4767b9789c6353ad5e826d1164

Comments

Ricardo Wurmus Nov. 3, 2023, 1:10 p.m. UTC | #1
Applied, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3a4bcd093a..e36593fd8e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10665,6 +10665,40 @@  (define-public r-scde
     ;; See https://github.com/hms-dbmi/scde/issues/38
     (license license:gpl2)))
 
+(define-public r-miamiplot
+  (let ((commit "beede9c5d6431b4d822aa42e064e01baeb5dd4a0")
+        (revision "1"))
+    (package
+      (name "r-miamiplot")
+      (version (git-version "1.1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/juliedwhite/miamiplot")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0wxxk1lk9jbf0imf59qp302ffasvs84idinkvzirs3dw9w3589n9"))))
+      (properties `((upstream-name . "miamiplot")))
+      (build-system r-build-system)
+      (propagated-inputs (list r-checkmate
+                               r-dplyr
+                               r-ggplot2
+                               r-ggrepel
+                               r-gridextra
+                               r-magrittr
+                               r-rlang))
+      (native-inputs (list r-knitr))
+      (home-page "https://github.com/juliedwhite/miamiplot")
+      (synopsis "Create a ggplot2 miami plot")
+      (description
+       "This package generates a Miami plot with centered chromosome labels.
+The output is a ggplot2 object.  Users can specify which data they
+want plotted on top vs. bottom , whether to display significance
+line(s), what colors to give chromosomes, and what points to label.")
+      (license license:gpl2))))
+
 (define-public r-millefy
   (package
     (name "r-millefy")