diff mbox series

[bug#68623,5/6] gnu: Add rust-fast-image-resize-2.

Message ID c64ccda68e6b1d0f4464fcdf1de490a81e2b6066.1705792641.git.jaeme@runbox.com
State New
Headers show
Series gnu: Add swww | expand

Commit Message

Jaeme Sifat Jan. 20, 2024, 11:30 p.m. UTC
* gnu/packages/crates-graphics.scm (rust-fast-image-resize-2): New variable.

Change-Id: Ifccaf0eeab21f20043b4a49d8d0a58f867e151a1
---
 gnu/packages/crates-graphics.scm | 35 ++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 11e4cb6706..90e130a754 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -1225,6 +1225,41 @@  (define-public rust-exr-1
     (description "Read and write OpenEXR files without any unsafe code")
     (license license:bsd-3)))
 
+(define-public rust-fast-image-resize-2
+  (package
+    (name "rust-fast-image-resize")
+    (version "2.7.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "fast_image_resize" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0nnm59h7dl2bpi5k2wcd7zz14nl00sa33jiipbjbn48f0i09ly6c"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f ; Unresolved import `testing'
+       #:cargo-inputs
+       (("rust-num-traits" ,rust-num-traits-0.2)
+        ("rust-thiserror" ,rust-thiserror-1))
+       #:cargo-development-inputs
+       (("rust-criterion" ,rust-criterion-0.4)
+        ("rust-image" ,rust-image-0.24)
+        ("rust-itertools" ,rust-itertools-0.10)
+        ("rust-nix" ,rust-nix-0.26)
+        ("rust-png" ,rust-png-0.17)
+        ("rust-resize" ,rust-resize-0.7)
+        ("rust-rgb" ,rust-rgb-0.8)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-walkdir" ,rust-walkdir-2))))
+    (home-page "https://github.com/cykooz/fast_image_resize")
+    (synopsis
+     "Fast image resizing with using of SIMD instructions")
+    (description
+     "This package provides fast image resizing with using of SIMD instructions.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-fast-srgb8-1
   (package
     (name "rust-fast-srgb8")