diff mbox series

[bug#53818,3/3] gnu: xorg-server-xwayland: Set 'repology-name' property.

Message ID c648a7af35de04f863e4ffed1b935b2f486ec869.1644147246.git.public@yoctocell.xyz
State New
Headers show
Series Add Repology updater | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen Feb. 6, 2022, 1 p.m. UTC
* gnu/packages/xorg.scm (xorg-server-xwayland):[properties]: Set
'repology-name'.
---
 gnu/packages/xorg.scm | 2 ++
 1 file changed, 2 insertions(+)

Comments

M Feb. 6, 2022, 2:15 p.m. UTC | #1
Xinglu Chen schreef op zo 06-02-2022 om 14:00 [+0100]:
>                      (lambda _
>                        (substitute* (find-files "." "\\.c$")
>                          (("/bin/sh") (which "sh"))))))))

FWIW this is wrong when cross-compiling,
this needs to use (search-input-file inputs "bin/sh") instead
such that a (cross-compiled) shell from 'inputs' is used instead of a
(native) bash from 'native-inputs'.

That's a bug in the old package definition though.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 14e35d19ae..ee45630596 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5520,6 +5520,8 @@  (define-public xorg-server-xwayland
                     (lambda _
                       (substitute* (find-files "." "\\.c$")
                         (("/bin/sh") (which "sh"))))))))
+    (properties
+     '((repology-name . "xwayland")))
     (synopsis "Xorg server with Wayland backend")
     (description "Xwayland is an X server for running X clients under
 Wayland.")