diff mbox series

[bug#67493,3/6] gnu: Add expected-lite

Message ID c633a12ed25c7bd7bb4a0950223dfac906a94547.1701112690.git.saku@laesvuori.fi
State New
Headers show
Series Update telegram desktop | expand

Commit Message

Saku Laesvuori Nov. 27, 2023, 7:26 p.m. UTC
* gnu/packages/cpp.scm (expected-lite): New variable.

Change-Id: I627bc4a811107b1c4fb9ed8f3e2a5b23043eb97c
---
 gnu/packages/cpp.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 5e35a03254..e35a17811e 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2977,3 +2977,24 @@  (define-public tl-optional
 the std::optional for C++11/14/17, with support for monadic operations added in
 C++23.")
     (license license:cc0)))
+
+(define-public expected-lite
+  (package
+    (name "expected-lite")
+    (version "0.6.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/martinmoene/expected-lite")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0d58nqh2fwdzdpln2wlnf898wyfxdnskq6ff33azbg92d5ibzys2"))))
+    (build-system cmake-build-system)
+    (home-page "https://github.com/martinmoene/expected-lite")
+    (synopsis "Expected objects for C++11 and later")
+    (description "Expected lite is a single-file header-only library for
+objects that either represent a valid value or an error that you can pass
+by value. It is intended for use with C++11 and later")
+    (license license:boost1.0)))