diff mbox series

[bug#64041] gnu: Add anarch.

Message ID c61d48201211ced27f47d2e10288f304a7f4d298.1686653095.git.iyzsong@member.fsf.org
State New
Headers show
Series [bug#64041] gnu: Add anarch. | expand

Commit Message

ashish.is--- via Guix-patches" via June 13, 2023, 10:45 a.m. UTC
From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/games.scm (anarch): New variable.
---
 gnu/packages/games.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)


base-commit: b188c41d930dbe8142c1f377d3c8f2580ff1277c

Comments

Ludovic Courtès June 18, 2023, 9:29 p.m. UTC | #1
Hey,

iyzsong@envs.net skribis:

> From: 宋文武 <iyzsong@member.fsf.org>
>
> * gnu/packages/games.scm (anarch): New variable.

LGTM! :-)

Ludo’.
宋文武 July 18, 2023, 12:18 p.m. UTC | #2
Pushed, forgot to close..
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8c00c2e66e..b53730f850 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -415,6 +415,40 @@  (define-public alex4
 The game includes a built-in editor so you can design and share your own maps.")
     (license license:gpl2+)))
 
+(define-public anarch
+  (let ((commit "2d78d0c69a3aac14dbd8f8aca62d0cbd9d27c860")
+        (revision "1"))
+    (package
+      (name "anarch")
+      (version (git-version "1.1d" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://git.sr.ht/~drummyfish/Anarch")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1lg9r6q1davn5yj181ccygmvaigvm8fr9q2s1bc77a1vkz68vzdk"))))
+      (build-system gnu-build-system)
+      (arguments
+       (list #:tests? #f ;no tests
+             #:phases #~(modify-phases %standard-phases
+                          (delete 'configure) ;no configure script
+                          (replace 'build
+                            (lambda _
+                              (invoke "./make.sh" "sdl")))
+                          (replace 'install
+                            (lambda _
+                              (let ((bin (string-append #$output "/bin")))
+                                (install-file "anarch" bin)))))))
+      (inputs (list alsa-lib libxcursor libxrandr sdl2))
+      (home-page "https://drummyfish.gitlab.io/anarch/")
+      (synopsis "Public domain 90s-style shooter game")
+      (description "Anarch is a small, completely public domain, 90s-style
+Doom clone shooter game.")
+      (license license:cc0))))
+
 (define-public armagetronad
   (package
     (name "armagetronad")