diff mbox series

[bug#68371] gnu: Add r-jaspar2020.

Message ID c61c85dc59f58ea507efe7016c59d2efface5b37.1704896557.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#68371] gnu: Add r-jaspar2020. | expand

Commit Message

nafkhamdc Jan. 10, 2024, 2:22 p.m. UTC
* gnu/packages/bioconductor.scm (r-jaspar2020): New variable.

Change-Id: I84f0fc2a7defc5d179ffc24aa1f30177cb3b3060
---
 gnu/packages/bioconductor.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)


base-commit: 537768018ee03a6a9a5562022a16b47ac287d131
prerequisite-patch-id: 103e1e7922398cbadee6250d96974c6b8ca89fdb

Comments

Ricardo Wurmus Jan. 10, 2024, 5:50 p.m. UTC | #1
Applied, thanks!  Note that I moved this to the Annotations section at
the beginning of the file.
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7c4272f8be..e4021fe756 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6003,6 +6003,27 @@  (define-public r-deconstructsigs
 closely reconstructs the mutational profile.")
     (license license:gpl2+)))
 
+(define-public r-jaspar2020
+  (package
+    (name "r-jaspar2020")
+    (version "0.99.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "JASPAR2020" version
+                              'annotation))
+       (sha256
+        (base32 "0nrp63z7q2ivv5h87f7inpp2qll2dfgj4227l4rbnzii38a2vfdr"))))
+    (properties `((upstream-name . "JASPAR2020")))
+    (build-system r-build-system)
+    (native-inputs (list r-knitr))
+    (home-page "https://jaspar.elixir.no/")
+    (synopsis "Data package for JASPAR database (version 2020)")
+    (description "Data package for JASPAR2020.
+To explore these databases, utilize the TFBSTools
+package (version 1.23.1 or higher).")
+    (license license:gpl2)))
+
 ;; This is a CRAN package, but it depends on Bioconductor packages.
 (define-public r-jetset
   (package