diff mbox series

[bug#72569,1/4] gnu: Add backward-cpp.

Message ID c5fb0d4b-3dd7-4eeb-19b3-15b5cc9ed192@disroot.org
State New
Headers show
Series gnu: openclonk: Fix build. | expand

Commit Message

Adam Faiz Aug. 11, 2024, 5:16 a.m. UTC
From edcd1203111fe557c22e4b9053d0dcf6cc690794 Mon Sep 17 00:00:00 2001
Message-ID: <edcd1203111fe557c22e4b9053d0dcf6cc690794.1723353069.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1723353069.git.adam.faiz@disroot.org>
References: <cover.1723353069.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Sun, 11 Aug 2024 08:40:08 +0800
Subject: [PATCH 1/4] gnu: Add backward-cpp.

* gnu/packages/debug.scm (backward-cpp): New variable.
---
 gnu/packages/debug.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Liliana Marie Prikler Aug. 17, 2024, 12:15 p.m. UTC | #1
Am Sonntag, dem 11.08.2024 um 13:16 +0800 schrieb Adam Faiz:

> --- a/gnu/packages/debug.scm
> +++ b/gnu/packages/debug.scm
> @@ -513,6 +513,32 @@ (define-public qemu-for-american-fuzzy-lop
>      ;; Several tests fail on MIPS.
>      (supported-systems (delete "mips64el-linux" %supported-
> systems))))))
>  
> +(define-public backward-cpp
> +  (package
> +    (name "backward-cpp")
> +    (version "1.6")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/bombela/backward-cpp")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +               
> "1b2h03iwfhcsg8i4f125mlrjf8l1y7qsr2gsbkv0z03i067lykns"))))
> +    (arguments
> +     (list
> +      #:configure-flags
> +      #~(list "-DBACKWARD_SHARED=ON")))
> +    (build-system cmake-build-system)
> +    (inputs
> +     (list libiberty zlib))
> +    (synopsis "Stack trace pretty printer for C++")
> +    (description
> +     "Backward-cpp is a stack trace pretty printer for C++.")
We might want to give this a better description, e.g. saying that it
prints out annotated stacktraces or something.
> +    (home-page "https://github.com/bombela/backward-cpp")
> +    (license license:expat)))
> +
>  (define-public aflplusplus
>    (package
>      (inherit american-fuzzy-lop)
Note: you should pick a wiser location, (e.g. below aflplusplus), so as
to not break this sequence of packages.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 2cdf87e266..4e652ba94d 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -513,6 +513,32 @@  (define-public qemu-for-american-fuzzy-lop
     ;; Several tests fail on MIPS.
     (supported-systems (delete "mips64el-linux" %supported-systems))))))
 
+(define-public backward-cpp
+  (package
+    (name "backward-cpp")
+    (version "1.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/bombela/backward-cpp")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1b2h03iwfhcsg8i4f125mlrjf8l1y7qsr2gsbkv0z03i067lykns"))))
+    (arguments
+     (list
+      #:configure-flags
+      #~(list "-DBACKWARD_SHARED=ON")))
+    (build-system cmake-build-system)
+    (inputs
+     (list libiberty zlib))
+    (synopsis "Stack trace pretty printer for C++")
+    (description
+     "Backward-cpp is a stack trace pretty printer for C++.")
+    (home-page "https://github.com/bombela/backward-cpp")
+    (license license:expat)))
+
 (define-public aflplusplus
   (package
     (inherit american-fuzzy-lop)