diff mbox series

[bug#67999] gnu: Add python-kalamine.

Message ID c5dabb6dbf23070662307f5120e534c82bc95df3.1703377209.git.leirda@disroot.org
State New
Headers show
Series [bug#67999] gnu: Add python-kalamine. | expand

Commit Message

Adriel Dumas--Jondeau Dec. 24, 2023, 12:20 a.m. UTC
* gnu/packages/python-xyz.scm (python-kalamine): New variable.

Change-Id: If13f258440bb35973b3d79a87fea68e4708845bf
---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)


base-commit: a8196632647b343f8e03c8f12fbdc0cc84ff90f6
prerequisite-patch-id: cefc174692b72660bf5ed4c03442f33dbaf6e784
prerequisite-patch-id: 6b1015959d122056b883e766306b0ff8ba30bde9
prerequisite-patch-id: a3116f7908bc9fdb237e4cde52260856b083596d
prerequisite-patch-id: db1d3d945579284d401944b18fcbc506a000714f
prerequisite-patch-id: 84bff5e4689979f565315edf96250ccc367f8fb8
prerequisite-patch-id: bd69d4115bc86b7d2739e9890625788f1fa5a006
prerequisite-patch-id: 0834ca6f4e7f1ed91b5dcb679096a953a6e36273

Comments

Sharlatan Hellseher Feb. 18, 2024, 7:49 p.m. UTC | #1
Hi,

Thank you for the patch.

It does not just update the version but also adjusts description,
 introduces custom check phase and reindent fields.

If it's possible may you isolate package update and place rest of
modifications in dedicated patch with change log annotation covering it.

Looking forward for v2!


Regards,
Oleg
Andreas Enge Feb. 29, 2024, 6:31 p.m. UTC | #2
Hello Adriel,

QA cannot apply your patch: The v2 supersedes the v1; so instead of first
creating the package in version 0.18 and then updating it to 0.30, QA tries
to update a non-existing package, which of course fails.

Could you simply send a v3 which introduces version 0.30 from scratch,
or otherwise said, a squashed version of the two commits?

Thanks,

Andreas
Sharlatan Hellseher March 2, 2024, 2:06 p.m. UTC | #3
Hi,

I've reviewed and amended the patch.

Applied changes for v2 [7/7]
- [X] Add copyright header
- [X] Update to the latest version - v0.33
- [X] Simplify arguments, preserve default 'check phase
- [X] Shift some inputs from propagated to native
- [X] Fix warnings from linter about synopsis
- [X] Simplify description, remove any OS related references.
- [X] Build, Lint passed locally

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cab44be011..b12a28e0e9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5881,6 +5881,24 @@  (define-public autokey
 flexibility and power of the Python language.")
     (license license:gpl3+)))
 
+(define-public python-kalamine
+  (package
+    (name "python-kalamine")
+    (version "0.18")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "kalamine" version))
+       (sha256
+        (base32 "1qcpn3kknxlh1jcragzgsihn5pysvs82lcrkvk1047im94rgp0i2"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-click python-lxml python-pyyaml python-tomli))
+    (home-page "http://github.com/fabi1cazenave/kalamine")
+    (synopsis "A cross-platform Keyboard Layout Maker")
+    (description "Creates keyboard descriptions for various operating systems
+from a ASCII-art template within a TOML document.")
+    (license license:expat)))
+
 (define-public python-dm-tree
   (package
     (name "python-dm-tree")