diff mbox series

[bug#71806,python-team] gnu: python-requests-toolbelt: Update to 1.0.0.

Message ID c5d0706325085bd7758cadcca8b7f5841e941318.1719505211.git.felgru@posteo.net
State New
Headers show
Series [bug#71806,python-team] gnu: python-requests-toolbelt: Update to 1.0.0. | expand

Commit Message

Felix Gruber June 27, 2024, 4:20 p.m. UTC
* gnu/packages/python-web.scm (python-requests-toolbelt): Update to 1.0.0.
[arguments]: Delete tests that are incompatible with urllib3 >= 2.0.
[native-inputs]: Remove python-mock; add python-pyopenssl and python-trustme.

Change-Id: I349bd9cef34cdbf7a51612e8b9d5dac59101d1bd
---
 gnu/packages/python-web.scm | 17 +++++++++++------
 1 file changed, 11 insertions(+), 6 deletions(-)


base-commit: e4ad2f178af65be6c8ca6e98a667787674cd8c82
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e8ead0ef12..0c0c433c5d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -49,7 +49,7 @@ 
 ;;; Copyright © 2021 Alice Brenon <alice.brenon@ens-lyon.fr>
 ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
-;;; Copyright © 2022, 2023 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2022–2024 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
 ;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
 ;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
@@ -3761,13 +3761,13 @@  (define-public python-requests-mock
 (define-public python-requests-toolbelt
   (package
     (name "python-requests-toolbelt")
-    (version "0.9.1")
+    (version "1.0.0")
     (source (origin
              (method url-fetch)
              (uri (pypi-uri "requests-toolbelt" version))
              (sha256
               (base32
-               "1h3gm88dcjbd7gm229a7x5qkkhnsqsjz0m0l2xyavm2ab3a8k04n"))))
+               "1ijvip427ki177ycrblcn1mfgsq7ixzpvqqfvidjn0a7s2is10bn"))))
     (build-system python-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
@@ -3777,9 +3777,14 @@  (define-public python-requests-toolbelt
                       (delete-file "tests/test_x509_adapter.py")
                       ;; Fails due to networking (socket.gaierror: [Errno -2]
                       ;; Name or service not known).
-                      (delete-file "tests/test_multipart_encoder.py"))))))
-    (native-inputs
-     (list python-betamax python-mock python-pytest))
+                      (delete-file "tests/test_multipart_encoder.py")
+                      ;; Those tests are not compatible with urllib3 2.0,
+                      ;; according to
+                      ;; https://github.com/requests/toolbelt/pull/356
+                      (delete-file "tests/test_sessions.py")
+                      )))))
+    (native-inputs
+     (list python-betamax python-pyopenssl python-pytest python-trustme))
     (propagated-inputs
      (list python-requests))
     (synopsis "Extensions to python-requests")